SMB mounted, but not in library


I have successfully mounted SMB share.
I can see it as a share under NAS, access it with root when SSH-ed to volumio RPi, etc…
But I can’t see anything in the Library of volumio WebUI.

I have tried update on NAS, MPD update - but no success.

Can someome please help me.


What you will get by command this command? tail /var/log/mpd/mpd.log


i am getting permission denied errors like this:
Dec 31 07:46 : update: Failed to open directory /var/lib/mpd/music/NAS/ENKI: Permission denied

I see that mpd is running under mpd user.
I can easily access folder with root and pi (su pi) users.
ENKI folder (nas share) seems to be under pi user:

drwx------ 1 pi pi 0 Oct 3 17:23 ENKI

What should i do now?
Thx for guiding me to resolve this issue.


I have the same problem. See my post "Update info on NAS Mount "

I had the same issue with my SMB/CIFS shares. The share mounts just fine, as user pi and as root I was able to browse through the mounted folders, but when creating/updating the database mpd ran into permission denied errors.
I tried adding user mpd to the “users” group and mounting with the “users” flag but it didn’t work.
The one thing that did work for SMB/CIFS was mounting with the “uid=mpd” handle. I would like to know how to het to mount my nfs mounted as user mpd as well to be able to have access to the sahre in able to build the database…

Someone out there ready to help out?