Small problems that happened occasionally

Volumio Information

Volumio Version: v2
Hardware: RPi4B
DAC:Gustard X16

I started using Volumio to stream music from the beginning of 2021. I have updated Volumio once I found there is newer version but there are a few small problems that keep happening occasionally.

  1. Alsa error: I kept Volumio running 24x7 and turn off the DAC when I am not playing music. I sometimes get the Alsa error when I turn on the DAC and play music (from NAS or UPnP). Sometimes power cycle the DAC solved the problem. If it is not working, unplug the DAC and plug it again sometimes work. If it still not working, restart the RPi 100% solved the problem.

  2. NAS missing: The whole library is gone. Update or rescan don’t help and I have to remove and remount the NAS. I think this only happened 2~3 times recently.

  3. WIFI dropping: I originally connected to 5G WIFI but it is so unstable. I have a touchscreen connected to RPi and it showed it is connected to the WIFI but I cannot control Volumio with web interface. I changed to 2G WIFI and it seems solved the problem except I recently found it cannot to WIFI and I have to restart ti solved the problem.

Just want ti report the issues and hope to understand what caused these problems. By the why, do you think daily reboot (by cron) will help?