SimpleEqualizer does not work with V2.799

I upgraded to V 2.799 and had to disable SimpleEqualizer to have sound.

I2s dac hw number changed. Chances are that enabling and saving conf will solve your issue

Ok, now working fines.


I have the same problem. After the new update (799) i have no sound.
I did a complete reset, and it worked. But when i install SimpleEqualizer the sound is gone and i have to redo everything.
I need the Equalizer, please help.

HiFiBerry DAC+ Pro RCA met Spacers with Raspberry Pi 4 Model B - 4GB


Can please try the following :
Remove the plugin.
Set your Dac and volume mixer.
install the plugin
enable it
let me kow

Hello balbuze,

I’ve tried this allready.
When i did a reset and set the Dac and other settings i have sound. When i install after that the plugin the sound is gone. Reboot doesn’t help. There is no sound at all, no radio, no tidal not even the startup sound. When i put back “the original Dac” settings the sound is still gone. When i remove the plugin i still have no sound. I have to do a reset to have sound again without Equalizer.
There is a second Equalizer, it has the same problem.


when you disable or remove the plugin, you may have to set the dac and mixer to be able to play something.
can you send your log using when plugin is enable:

and if possible the content of /etc/asound.conf and /data/configuration/audio_interface/alsa_controller/config.json

I shall do upcomming weekend. I am on a short vacation at this moment.
Thank you for willing to help!

Hope this would not be standard procedure after any Volumio update.

We as Volumio can have control of Volumio itself and check everything is fine for each update.
With plugins this becomes next to impossible to test everything and this is demanded to plugins authors…

We’re working to incorporate a standard way to edit audio out for plugins, so those problems won’t happen again.

1 Like

Please see No sound out of HiFi Berry DAC + with Volumio2 (2.799)


I have done as asked. You have the report.

It is still not working for me.

I am going to reinstall again, then i have sound but without equalizer. I hope this bug is solved soon in a quick comming new version update.

Hope to hear from you.


@balbuze @volumio

You have the report. I’ve send it a few days ago. I hope to hear.


The new update didn’t fix the problem…


where is you log?
can you give the link here please?

Here is my log report after Simple EQ plugin is made Active. Thanks for all your help.

Here is my log report after Simple EQ plugin is made NOT Active.

Have you removed the plugin, reboot, configure output and volume mixer and reinstall the plugin?
I see an error with lib_asound that appears when Volumio is updated. It brakes something with this lib. The only is to reinstall the plugin.
Let me know
Edit: you may have to do

sudo apt remove libasound2-plugin-equal

Before reinstalling the plugin.

Followed your instructions including the sudo apt remove command. Still no sound.

Have you reinstalled the plugin after that? I see

ALSA lib conf.c:3523:(snd_config_hooks_call) Cannot open shared library

As if it was not installed.
If this the case, what return

sudo apt install libasound2-plugin-equal

What it working before with your hw?