Shutdown command not stopping my device


I’ve installed Volumio 2.526 on an Intel board. Everything works perfectly fine. A lot faster than my Raspberry pi. But…

When I issue the shutdown command via the menu, the gui is stopped, netwerk is stopped (smb connection lost) and music stops playing. But the device itself is not stopped. The led is stil on, the device is stil using its nominal power and it can’t be turned on or off by pushing the button on the device. The only thing left to do is to disconnect the power.

After restarting the device, I tried ssh and issued “sudo shutdown -h now”. This worked perfectly well. The application is stopped and the device is turned off. The power consumption dropped below 1W and the led turned off. Restarting the device with the button on the device works fine now.

To make things more complicated… pushing the button on the device while Volumio is running, will stop the music, the gui and the network, but the led is stil on and the device hangs. This is the same result as shutting down the system via the menu in the gui.

Is this a known issue? Is there a solution or workaround?


My config:
1: Intel Celeron J1900, 4GB RAM, 500GB SSD, no WiFi
2: Raspberry Pi 2, 500GB SSD via USB, WiFi only
+200 albums

A short update on the issue.

‘sudo shutdown -h now’ Is not working. I’m not sure if it is not working anymore, or if it hasn’t been working at all. I’ve been doing some experiments with Ubuntu on the same device. Shutdown -h is working in Ubuntu. Maybe I got confused and sought it was working in Volumio as well.

Anyway, The only way the shut down the device is to pull the plug or to hold the power button for several seconds.

I’ve been searching several forums. It appears that some Linux distro’s suffer from this problem. It seams to be bios related. Some distro’s have delivered patches, others haven’t.

Second update:

Based on what I found in the Internet, I did several experiments.

Nano /etc/default/grub
Change GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash”
To GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash acpi=force”
Run update-grub.
Unfortunately update-grup was not installed. I (re-)installed it. ran it:
but then I got: “/boot/grub does not exist”. This is a dead end.

2. Disable USB3 legacy support in BIOS
I have AMI BIOS. The board has 4 USB2 ports and 1 USB3 port.
Unfortunately I couldn’t find USB3 legacy support in the BIOS. There is mention of USB2 legacy support, but several posts specifically mentioned USB3 legacy support. So this is a dead end for now as well.

3. Change UEFI power management settings in BIOS
Although I’m not sure of any side effects of turning this power management off, I opened the advanced setting of the BIOS. Unfortunately I couldn’t find UEFI power management settings. This seems to be another dead end.

But I stumbled upon another setting. There is a setting to use the system for Windows (specific mention of 8.1) or Android. I changed it from Windows to Android. This did the trick. I can now shutdown Volumio from the UI. Sudo shutdown -h now, also works fine now.

My problem is solved for now. But I really wouldn’t know what the OS-selection in the BIOS is designed for. I can’t find any documentation on it. I also wouldn’t know if this is a permanent fix or if the problem might re-occur in an future release of Volumio.

I’ve seen many articles on the Internet about similar problems in several Linux distro’s. Some of them have been solved in release updates or patches. In my humble opinion it would be good if Volumio also solved this in their software. I think Volumio should be ready to run on new Intel hardware without changes in the BIOS.

Is this one of those x86 from china? Unfortunately they are known for not being well documented (other than stamp-sized quick start guides).
I had my own experience with them, some worked fine (and some went south for other reasons later), others had issues similar to yours.
USB legacy is for older 1.1 versions, you should enable if you can, do not worry about usb 2.0 and 3.0.

You can still set acpi=off (or to something else), but as we build our own initrd, you cannot use grub-update (removed).
This is what you can do

  • for UEFI boot, update /boot/efi/BOOT/grub.cfg (and when working, grub.tmpl as wel)
    look for the cmd line parameters with the volumio settings (2 occurrences) and add “acpi=off” (or whatever you wish)
  • for LEGACY boot, update /boot/syslinux.cfg (and when working, syslinux.tmpl as well)
    look for the cmd line parameters with the volumio settings (1 occurrence) and add acpi=off
    Do both the cfg’s at the same time, unless you know what boot type you are using, you can wait with the .tmpl when it is working:

It is very difficult for us to create an x86 image which covers the thousands of possible x86 hardware combinations out there.
Especially because we only have a handful of mainstream devices available for testing. Be glad yours works, don’t touch it :wink:

Manufactured in China and supplied with a quick start guide that required extra strong reading glasses :ugeek:

Thanks for the tips. I do understand the issue with the huge amount of hardware types out in the market.
As suggested, I won’t touch the box anymore, since it is working.

I’m considering adding a second SSD and installing Kodi in a multiboot environment. This issue will come back and haunt me without a doubt.

I have similar problem with my HP mini 210, can you tell me how i can edit those boot options?

just read, please!
Two posts back you find the details, other than in syslinux.cfg and grub.cfg you cannot edit boot options.