Sharing USB library drive

This is an area I resolved successfully in my original installation. Today I upgraded my 3 rpi’s to Volumio3. Now I can’t share the USB Library drive I have connected to the Pi4.

The drive mounts and I can play music from the library on that pi. When I go to settings on either of the other two and try to add network drive nothing shows up in the autoscan. If I use the path I had used previously - usb/VolumioLib it isn’t recognized.

In the smb config file it looks like this
[USB]
comment = Volumiolisteningroom USB Music Folder
path = /mnt/USB/VolumioLib
read only = no
guest ok = yes

where Volumiolisteningroom is the name of the pi4 install and VolumioLib is the drive containing the library.

I believe this is the same as prior to the change to Volumio3.

What am I missing.

Thanks

@sharberger Volumio v3 includes drive sharing, so no need to set up samba.

On your Pi3 go to Sources, click on Add New Drive and you should see your Pi4 come up. Select USB and then you should change some of the fields it auto fills.

Change whatever is in NAS IP Adress to the IP address of your Pi4, and the Alias if you want.
You may need to fill in the Username and Password, though I don’t have to with my volumios.

Hope that works.

@SimonE Thanks for the reply. The issue seems to be that when I click Add New Drive - it comes back as no available drives. The Pi4 does not show up.

Trying to manually fill in the fields hasn’t been successful either.

Any thoughts on what is preventing the Pi4 from showing up?

@sharberger One possibility is that the sharing functions only work with Premium, I don’t know as I have Premium and it just worked. Another possibility is that you’ve inadvertently done something to Volumio’s Samba settings when customising it. I really don’t know, just what I’d check.
I had various multiroom issues that were caused by my tinkering. After a fresh install, everything worked perfectly.

@SimonE - thanks again. I did a Factory Reset after I read your first response. I am a Superstar subscription level, so I should get any features.

Like I said. All of this worked prior to moving to Volumio3. I would just like to get back to what I had prior to the switch and then try to get synchronous multiroom going. That’s a lower priority.

I may try a total rebuild on the PI4. Reflash the SD card and see what happens.

@sharberger I think that’s safest. See if you can find the shared drive before configuring all the other things you want.

Success-
Purchased a fresh sd card. But before going through that process I thought I’d take a look at the USB drive. I shutdown Volumio, disconnected the drive and plugged it into my MacBook. Ran Firstaid under disk utilities. It didn’t report any issues so I plugged it back into the pi4 and started up Volumio.

At this point, in theory, nothing is different to prior BUT when I went to settings in my other Volumio installs and added the IP address and path for the USB drive it worked.

Still didn’t show up automatically when Volumio scanned, but adding IP and path worked.
No idea what was different this time except perhaps Disk Firstaid did something behind the scenes.

One of those you can put down to persistence wins. Glad it’s working. Enjoy!