Severely tech challenged old guy needs help

I had volumio working on my raspberry pi based TeraDak streamer but had to change internet providers. I am trying to connect to new wifi but can’t. When I have it hard wired I can connect to volumio.local. If I try to set up wireless it connects to wireless Hotspot but not to my network. I’m lost and it doesn’t help that I don’t understand most of what I read in this forum. Please help!

Hi, if you are connected via Ethernet, you may go to the settings menu in the web interface and change your previous wireless settings to the current one. Don’t forget to save the new settings. After a reboot the Pi should be able to connect to your wireless network again.

I did this but when I try to connect to my new wifi it just connects to “wifi hotspot” instead. No matter how many times I try it doesn’t connect to my wifi even if I turn off wifi hotspot.

Is your WiFi signal strong enough and did you try to reset your modem already?

Hi and welcome!
Can you be add some more info?

  • Can you connect to your new WiFi with other devices (e.g. PC, mobile phone)?
  • When you say „it connects“, what do you mean by* it*? Volumio?
  • Is „automatic IP“ (aka DHCP) enabled in the Volumio settings? Is DHCP enabled on the Router?
  • If you disabled DHCP, are the IP addresses on Router and Volumio matching? Did you configure the right Subnet mask and Gateway?
  • I would recommend to set all Settings to automatic at first

If you did not change the setting, Volumio will act as a WiFi Hotspot, if it does not find a Network Connection. But it will not connect to itself.

I have a similar setup with LAN connection, and just played through it step by step:

  • enable wireless
  • Save
  • Between the „wireless Settings“ and the „Hotspot settings“ section, I then get a list of WiFi-Networks in the neighborhood.
  • select the Right one and enter the password
  • connect


the fast way is reinstalling it all. all will be set again i guess some settings changed.

The wifi is strong and I had no problem connecting TV, phones, and computers. I have gone all the way back to downloading volumio and re-flashing the SD card. With a ethernet cable I can connect to volumio.local but even if I put in my wifi name and password it doesn’t work. As soon as disconnect the ethernet cable I can’t use either a browser or the volumio app to access my device

do you have pi version and volumio version for use.
try a static ip instead of a dhcp.

I belive its a pi 4b and the volumio I am using now is the latest because I just downloaded the .img today. I am neither sure where to find the ip address or how to use it. I am horribly "tech challenged " which makes this even more difficult.

Welcome to Volumio!

Which country are you in? Is your Wi-Fi network on a country specific channel?

Would you share some system logs please?

Preferable from a fresh reboot, when connected to the Ethernet, and after entering Wi-Fi details.

I am in the US. I don’t think my wifi is country specific. I appreciate everyone trying to help. I will try to figure out the system log thing in the morning but I’ve got to get some sleep now.

use a network scanner to scan and check if raspi is in the network. try to connect using its ip address.

the name for wifi can raspi.station while with ethernet, its name can be raspi.local. better use the ip address and check if you can connect from your phone to its browser.

1 Like

Hi, please make sure you do not have dots, ie “.” characters in the password or WiFi network’s name. If you do, Volumio will accept the settings but can’t save them. Therefore the Volumio will think everything is fine and set but after it tries to save the settings, it won’t and after you restart it, it won’t connect to WiFi.

No dots in network name or password.

Go to Settings/Network Status. What does it show under wireless? If it’s not what you expect or not what you want, go to Settings/System and click on Run First Config Wizard. When it gets to selecting connection, select the wifi you want. Save it. Go back to Settings/Network Status. Does the correct wireless connection show up? If not, what does it show? Mine shows Honeyhome 5.0 with an IP Address of

I’m trying to remember how I created a fixed IP address. It’s not hard, but I’m not a Linux guy, so everything’s a challenge.

Shows “hotspot” with a ip address. I have run first configuration wizard and am unable to connect to my network and when I go back to network there is no wifi connection. If I try to connect in the network section that is when I get the Hotspot connection. My network name and password have no dots but my network name does have a dash in it. Could that cause a problem with volumio?

I don’t think so. My wifi connection has a decimal point in it. Volumio doesn’t seem to care. Have you tried using Run First Config via the hotspot rather than ethernet cable?

  • If your device has wireless capabilities (and a supported Wireless card) Volumio will create a Wireless network called Volumio, the default password is volumio2
  • The Hotspot mode will allow you to connect to your Wireless network without the need for a wired connection, just connect to Volumio Hotspot and configure your network in the Network options page
  • Once your Wireless network has been configured, Volumio will automatically disable the Hotspot
  • If, for whatever reason, your configured Wireless network is not available (e.g. password change), Volumio will automatically re-enable the Hotspot; in case of a connection lost a reboot is needed in order to reactivate the hotspot, since the feature is triggered only at startup. This feature is disabled by default and can be activated by enabling the option Hotspot fallback located in Settings → Network
  • You can change the Hotspot options in the Network options, such as its name, password and channel (useful if you experience poor Hotspot performance)
  • Once in Hotspot Mode, Volumio can be reached with IP or via http://volumio.local as usual

IOW, I would pull the cable, connect to hotspot, go to System/Network, scroll to bottom of the page. You should see all the wifi connections available. If you don’t, there’s something else going on. I mean, the list should be essentially the same list you’d see when connecting your phone.

Hope that helps.

you got a wrong ip use a static ip …

1 Like

Can you try the following

– Reboot your volumio
– Connect via network cable
– Open the http://volumio.local/dev page in a tab
– Go to the Settings>>System in another tab, and hit the Run first config wizard button. Go through the stages and try and connect to your network
– Once it fails, head to the other /dev tab, and share the system logs

That should give us a better idea what is happening!