Samba share - not all folders are shown!

Hi, first of all many compliments, great work with Volumio! :smiley:
My setup:

  • Gigabit LAN + wifi
  • Ubuntu Server workstation with some disk shared with samba, everything working fine accessing from Windows client, android etc…
    and also with DLNA (Serviio as media server + BubbleUPnP)
  • Raspberry PI 2 with Volumio, cable connected to the LAN
  • TEAC UD-501 as DAC (wonderful!)
  • Android smartphone as control point, web-ui working fine! (also tested BubbleUPnP with Volumio as Renderer)
  • Also tested MPDroid and Mupeace, same behavior of web-ui, so everything is working fine

I only have one problem, and it appears the same way with web-ui, MPDroid and Mupeace, so I think is related to MPD:
I can’t see all my shared folders, only a part of them (let’s say a 80%), what can cause this kind of problem?
Path length? Flac files with some peculiar character in filename?
When I use BubbleUPnP with Volumio as Renderer, I can see all my folders without problems.

Many thanks in advance!

Little forward into the problem: I’ve tried RuneAudio, same hardware, same configuration, and it can see all folders,
so I think the problem could not be related to MPD. Maybe debian vs Archlinux (kernel) ?

Thanks in advance

Hey boys, no ideas ?
I recently had a similar problem with Serviio and DLNA, related to a not correct way of Java
to initialize Locale Configuration to UTF-8 (solved with a modified init script).
Can it be something similar? Do you need more informations?
I hope Volumio 2 will not exhibit this behavior with my setup, I’ll hopeful wait.


Having the same issue. Runeaudio see my music folder (on a server running open media vault) but Volumio doesn’t see any of the folders. The mount is fine as I can get to it via the terminal. Can’t be a question of indexing as it’s had hours I i Don’t have a massive library