RPi2B + JustBoom Digi HAT - No Outpu


Hope this is an easy fix, I’ve done some googling and fiddled about a bit, but I’m still not getting audio output. Playback options are set to:

Output Device: JustBoom Digi Boards
DAC Model JustBoom Digi Boards

Version Info:

Raspberry Pi 2 Model B
Hardware Revision : a21041
JustBoom Digi HAT
Raspbian GNU/Linux 8 (jessie)
Linux volumio 4.4.9-v7+ #884 SMP Fri May 6 17:28:59 BST 2016 armv7l GNU/Linux

I’ve also updated /boot/config.txt as per a troubleshooting note I read somewhere

initramfs volumio.initrd

Also ran an apt-get update and an apt-get upgrade and it errors out, the I try to force it:

root@volumio:/home/volumio# apt-get -f install
Reading package lists… Done
Building dependency tree
Reading state information… Done
Correcting dependencies… Done
The following extra packages will be installed:
systemd systemd-sysv
Suggested packages:
The following packages will be upgraded:
systemd systemd-sysv
2 upgraded, 0 newly installed, 0 to remove and 48 not upgraded.
1 not fully installed or removed.
Need to get 0 B/2248 kB of archives.
After this operation, 6144 B of additional disk space will be used.
Do you want to continue? [Y/n] y
debconf: delaying package configuration, since apt-utils is not installed
(Reading database … 21520 files and directories currently installed.)
Preparing to unpack …/systemd_215-17+deb8u6_armhf.deb …
Unpacking systemd (215-17+deb8u6) over (215-17+deb8u5) …
dpkg: error processing archive /var/cache/apt/archives/systemd_215-17+deb8u6_armhf.deb (–unpack):
trying to overwrite ‘/usr/share/dbus-1/system-services/org.freedesktop.systemd1.service’, which is also in package systemd-shim 9-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
addgroup: The group `systemd-journal’ already exists as a system group. Exiting.
Processing triggers for dbus (1.8.20-0+deb8u1) …
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any ideas?



Hi Bill,

can you confirm that the hardware works correctly?
We have tested all our boards with Volumio and found no problems

I don’t think you need to but this is our guide for Volumio
justboom.co/software/config … h-volumio/

I’ve tested the amp with another optical and coax source which works correctly (DVD Player). I have tried both Coax and Optical on the JustBoom and I don’t get output from either port. Are there any further hardware tests I can do?



Any know how I can test the hardware?

Hi Bill,

sorry for the late reply, didn’t see the alert for this post thread.

Could you please try with a different OS so that we exclude software and configuration issues? Maybe have a go at OpenELEC or OSMC
You can find our guides here https://www.justboom.co/software/

I only get time on Wednesdays to work on this, so tried Max2Play which worked first time. So the hardware is fine.

Volumio suits me better, so I’ll try the previous revision next week and report back,



Hi Bill, sorry but I missed this thread. The Justboom digi just works out of the box, without the need for any additional settings. I think it was not working because you manually edited some configuration files (you should not do it, as volumio is designed to work only if configured via the UI).