RPI2 running 1.55 keeps dropping wifi connection - help


I’m a newbie running volumio 1.55 on a RPi2 and everything seems to be running fine except that after a few minutes I loose my wifi connection and because I can’t access my network through good old cat5 my RPi dissapears into a blackhole. I’m currently using an Edimax EW-7811Un though this is the second USB adaptor this has happened with. Hopefully it’s something simple that I’m missing.

Many thanks!


Try this:
Create a new 8192cu.conf file (using the nano editor) in the following location

insert the following code

options 8192cu rtw_power_mgnt=0 rtw_enusbss=0

This will disable the power management and prevent the wifi (ew-7811un) from going to “sleep”.

Thanks for this! I will give it a go when I’ve figured out a few things lol. Ive done a search on google and dropping wifi connections seems a pretty regular problem for Raspberry pi’s :frowning:

Just to clarify.
The wifi dongle Edimax EW-7811un and many similar wifi dongles very popular with the raspberry pi ship with power management enabled by default. If left idle for a short time the Ew-7811un goes into power saving mode and the wifi connection is lost. In order to disable power management implement the code in my prior post. The wifi connection will now be always up.


Right, progress to date… Being a complete newbie to rpi I’ve slowly worked out nano and followed your instructions but when I come to save it all I get is ‘error writing /etc/modprobe.d/8192cu.conf: permission denied’

Any ideas? I sense that I’m getting closer at least lol.

Many thanks,

OK I think I figured out the permissions issue using sudo nano (it went on to save the file but I’m not sure if this is correct procedure?). After this I booted up and although it took a while it found the wifi network it got there in the end. However, it dropped the network just as quickly as before (it maybe holds it for a minute or two max). The adaptor is in a powered USB hub and is blinking away happily but no connection is to be found. I have read of another fix in addition to the one posted above pinging the router every minute or so.

Any thoughts gratefully received. Many thanks,

You are right, you need to sudo nano /etc/modprobe.d/8192cu.conf . To quit and save type press CTRL and X and say yes (or Y).
But can’t said if this trick works…I’ll test it with a similar usb wifi dongle and the same problem of deconnexion

Thanks for that - that’d be great. Let me know if you find anything.

So I tested it with my problematic wifi dongle. Since yesterday I never lose connexion. Before, most of the time, the system was unreachable…
So it works ! :smiley:

Lucky you! I wish I could say the same about mine. I restarted my pi and got to listen to a bit of spotify before the connection went down maybe I’ve got something wrong so will try again. Just work damn you!! So frustrating :frowning:

I imagine you have checked the content of the file you created. But recheck its name and place and what is in it… Good luck :wink:

The WiFi adapter 8192cu kernel module has power management enabled by default. You can check the power management status:

cat /sys/module/8192cu/parameters/rtw_power_mgnt

If the value returned is 0 then power management is OFF, if 1 power management is ON.

after creating the file: /etc/modprobe.d/8192cu.conf
insure that it contains: options 8192cu rtw_power_mgnt=0 rtw_enusbss = 0

Reboot! Check the power management status.

rtw_power_mgnt=0; // disable power management
rtw_enusbss = 0; // default, disable USB autosuspend

The above works with any WiFi dongle such as the EW7811un dongle using the RTL8188CUS chipset. To check your chipset:

pi@volumio:~$ lsusb Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter Bus 001 Device 004: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
The WiFi chipset is listed as shown above.

If your WiFi dongle is inserted directly into a Raspberry Pi, model B+ or Pi2 that supports high USB current consumption add the following code to your:
file… It limits the total current drawn by USB peripherals. This is 600mA by default, but now will be increased to 1.2A via software.:


and reboot

The WiFi dongles draw considerable power. Many WiFi problems are fixed with good power.
Check that you have a good quality 2 amp 5 v power adapter with a high current cable for the Raspberry Pi.

I have had wifi connection problems. This is how I solved them:

  1. use a dongle that supports power management
  2. disable power management for the wifi dongle
  3. put the RPi n permanent “performance” mode
  4. use a 2A PSU to avoid and PSU doubts

Thanks guys!

Well, progress of sorts - I think! Volumio now seems to be pretty reliably showing up as being connected to my home network. However i still can’t access the relevant volumio page (volumio.local or through the ip address). All I get is a page notifying me that the page is not available.

Any thoughts or ideas? Cheers!

I assume you can ssh to the pi. Is that correct?
If so verify that MPD is running

sudo netcat localhost 6600

response should be:
OK MPD 0.19.0

Consider restarting MPD:

sudo /etc/init.d/mpd restart

What is your result?

Success! Still the odd glitch but nothing like before. On the whole everything remains connected!! It was a typical newbie issue where I hadn’t copied the code exactly. Strangely the wifi dongle prefers to be placed in the pi rather than the usb hub but hey that’s a mystery for another day for the moment I’m going to enjoy playing with volumio over the wifi.

Thanks for all your help - I couldn’t have done it without you!