RPI2 latest Volumio occasionally drops connection

Hi,
I use RPI2, latest Volumio 2 ( up to date) , with wifi dongle (power-management OFF). I have two of these. Both have manually set IP in the router (static in volumio does not work with radio as it seems).

Both occasionally drops the connection and becomes unreachable or more often with the running volumio circle for quite some time (sometimes several minutes). In the former case “F5” does not work but it will sometimes just come back after a while, else the is only one way to solve it - restarting by unplugging the AC. In the latte case using “F5” sometimes works but most often it is just to wait - the system so to say “lagg”.

My router says they are online.

It seems to me that this only occur when I have not used Volumio for a while - but I have checked that the WIFI-powermanagement is off. Maybe it is a feature that suspend Volumio if not used? If that is the case is there any way to turn that feature off?

One solution could of course be to ping the volumio every X minutes. I have not tried that.

Does anyone have the same problem? Any solution?

Best

/ArtmanH

Hi,
unfortunately I face the same problem. I run 2.041 on a RP3.
Like artmanh volumio first connects to the network and works normally. Then the interface becomes sluggish at some point (usually a matter of minutes). It’ll still play music, though, I just can’t communicate with it. Most of the time it is still listed as connected to the network by the router, but just not accessible. Sometimes, however, it disconnects entirely and creates the volumio hotspot again.

With 2.029 this problem didn’t occur, but I also flashed a new OS on my router in the mean time. Not sure whether it’s just an unlucky combination…
I’d be glad to hear suggestions.

Best,
konstable

Same problem here.

My RPI2 works fine at the beginning, we set an Internet Radio and keeps playing. RPI2 is connected over WiFi and the router works fine.
If by any chance the Web browser (latest Chromium on Ubuntu 16.04) is closed or the page is refreshed then Volumio on RPI2 is not reachable anymore.

The application keeps running as it’s playing Internet Radio but the web UI is gone completely. So IP connection is not the issue, even the Router still shows it.

There is no way out if not switching off and on RIP2, but that caused a disk corruption.

So it’s quite a serious bug that needs some attention. We love Volumio but it’s not as reliable as it used to be.

Same here.

RPi3 / official touchscreen with Volumio 2.041
Ethernet connection with static IP.
Wifi and hotspot switched off.

While playing MP3 from Synology NAS mounted as SMB/CIFS, Volumio stops playing now and then. Time circle on UI continues to progress.
Sometimes, sound comes back after few seconds or minutes, sometimes I have to reboot Volumio to recover.
During sound interruption, NAS is no longer listed in Volumio UI, so it seems NAS connection is dropped.
Volumio.local is no longer reachable over network from a PC browser.
Ui displayed on touchscreen is very slow.
It is not a home network issue as I am still able to ssh to Volumio during NAS loss.
Any advice to fix it ?

Edit : looks similar to issue described here

Yes confirmed, I can still ssh to RPI. It’s the UI that is gone completely.

Hello,

In /boot/config.txt, gpu_mem is set to 16. This leads Volumio to boot on cutdown kernel.
Setting gpu_mem to 32, at least, allows Volumio to boot on standard kernel.
I have set gpu_mem to 64 and I am no longer experiencing NAS connection drop out.
Hope this helps.

This works for me very good. I also had problems with my Android tablet, when scrolling trough my NAS music folder it was always freezing when I was scrolling down or up. This problem was also solved. This scrolling problem did not appear with my Android mobile phone. Thanks a lot for this solution.