RPI2 + ES9023 doesn't work :-( [Solved]

Hi everybody !

I’m not good in english (i’m french) so, excuse me and thanks in advance…

I bought 2 weeks ago, a dac : audiophonics.fr/fr/dac-diy/a … 10295.html for my raspberry pi 2. I installed vlumio and it worked with a other dac but not with this one. The RPI recognized it (aplay command) but there is no sound…

There are 2 photos that i took :

Thanks in advance !



Hi Maxime,

nothing wrong with your english :slight_smile:
I would connect the GND pin (next to MCLK) to a GND pin on the PI Pin header as well.
Perhaps the analog circuit does work otherwise.
Did you choose the correct I2S driver?

Hey, I tried and it worked ! But, why ? I don’t know…

But now, i have an other problem. I bought a LCD screen on Ebay : ebay.fr/itm/121787323774?_tr … EBIDX%3AIT

And i tried to connect it by this way :

Maybe i could open a new post for this request ?


Making an other topics would be preferable, makes it easier for others who have the same questions

Well, for one: the pin is not there because the designer thought two times GND is better than one :laughing:
Obviously this is related to different circuits on the board, people at Audiophonics (Teradak?) could probably tell you more.

Tanks guys ! See you on another topic :wink: