RPi with official 7" Touchscreen, cannot operate volumio

Hello there.

I am new to volumio and tried to install volumio-2.587-2019-06-11-pi.img.zip on my Raspberry Pi 3B+ via a 4GB SDCARD, then on a new 32GB SDCARD. Interestingly the behaviour is exactly the same.

So what I did was to simply boot the Pi with the volumio image and wired lan connection and after some time I was able to connect to volumio.local. In there I could configure volumio for wireless LAN, configure access to my NAS and even play music on the web interface. So far so good.

The next step was to activate the TFT and touchscreen panel. It is the official Raspberry 7" TFT, and it is active even during boot. So when I installed the touchscreen plugin and rebooted the device it showed a mouse pointer on a grey background. So I found this page (touchscreen-only-grey-with-mouse-pointer-t8272.html) and installed all available updates (during which I had to go into interactive apt to respond to some UI questions), then I also installed the chromium browser.

After that volumio boots up ok, starts the browser and displays the same UI as I can see with the browser from another PC. So far so good again.

However Volumio now does not play songs any more. While the UI both on the touchscreen and in the remote browser operate well to configure volumio, any tap to play a song seems to have no effect. Also when I try to select a song from my NAS library it seems the volumio software seems to reboot. After all I hear the startup sound.

In some forum I found a hint this may be bound to no space on the SDCARD, so I bought a brand new one hence the switch from 4GB to 32GB. But the results are the same.

Did I install the touchscreen right? Why did I have to acknowledge some question manually when trying to run apt-get update? Why did I have to install chromium manually? Are these the right steps at all?
And how can I find out why volumio after the upgrade no longer likes my synology nas? (I entered vers=2.0 as extra parameter to the CIFS share to make it work before touchscreen setup)


So I just stumbled over a new release volumio-2.598-2019-07-26-pi.img.zip.
After burning and placing the 32GB card into the Pi Volumio started up and I was able to operate it via the web interface.
I added my nas share, tested to play internet radio and a song from my nas which both worked. Then I went for updates (just got the message I am already running the latest version) and installed the Touch Displaz plugin 1.0.0.
After activation of the plugin and restart of the Pi the screen still remains in text mode. Not even the mouse pointer occurs on the gray background.

I logged on with a keyboard (and my touch display) on the Pi directly and ran ‘apt-get update’. as before I got an error message, and this time I am writing it down:
E: dpkg was interrupted, you must manually run ‘sudo dpkg --configure -a’ to correct the problem.
When running that command the system shows a text interface that allows me to select the keyboard, which continues by just pressing Enter.
Rerunning ‘apt-get update’ shows errors on jessie/main armhf and jessie/main sources.

So finally I trz to run ‘apt-get upgrade’ and get the error message ‘No space on left on device’.

Indeed I find out that both the /static (324MB) and / (262MB) filesystems are used at 100%. My 32GB SDCARD is not used as it could.

This result looks different to what I had before: The touch screen is not used at all, but I can still play music through the remote browser UI.

Having discovered this thread touch-display-plugin-installation-hangs-t5677.html
I am trying my setup again - with different sequence of the steps.

After burning and placing the 32GB card into the Pi Volumio started up and I was able to operate it via the web interface.
I added my nas share, tested to play internet radio and a song from my nas which both worked. Then I went for updates and was offered version 2599. The upgrade took some time.

Then I connected to the volumio console and typed
apt-get update -> this did not fail
apt-get upgrade -> this reported:
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Although I did not have any further hint I ran
dpkg --configure -a
and received some dhcpcd dialog page asking whether I’d like mz /etc/dhcpcd.conf changed
I answered N
After that running apt-get update and apt-get upgrade did return another error:
Errors where encountered whle processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
Another run of dpkg --configure -a did not reveal any new stuff.

Just to be sure I rebooted volumio and returned to the GUI. In there I installed the Touch Display plugin.
During that I can see a prompt to choose my keyboard configuration without a chance to select anything.
Back on the console I try to run apt-get update but the necessary files are still locked so I need to reboot.

Now apt-get update shows:
E: dpkg was interrrupted, zou must manually run ‘sudo dpkg --configure -a’ to correct the problem

Running that command I can select the keyboard and finally run apt-get update and apt-get upgrade with the error message about the firmware-ralink. Back in the GUI it seems the touch display plugin is not installed so I try to do that again. This time the installation seems to finish.

After I activate the plugin I can reallz see the volumio UI on the touchscreen. This time volumio reacts to some of my taps at the touchscreen. E.g. I can try to find a song I’d like to play, and this time the system does not reboot but it also does not show me any song list.
When playing the last played song that is still visible on the screen there is no reaction when I click the plaz button though.

So this time volumio seems partly operational. Good work, but we are not yet finished…