Rpi-update does not work [SOLVED]


I just received the HiFiberry DAC and I have to say it is AMAZING. Absolutely outstanding quality sound. Way more clean and stable than Musical Fidelity M1 Dac (650e DAC) and an Exposure DAC (1000e DAC) which couldn’t even reproduce the sound without cracks and glitches.

However, I still suffer some troubles with the reboot/power off function with first version of Volumio. That’s why I downloaded the 1.1Beta, but discovered that the IS2 support got broken so rpi-update was needed. I tried rpi-updated and got this:

*** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS *** Performing self-update --2014-01-05 10:58:54-- https://github.com/Hexxeh/rpi-update/raw/master/rpi-update Resolving github.com (github.com)... failed: Name or service not known. wget: unable to resolve host address `github.com' !!! Failed to download update for rpi-update! !!! Make sure you have ca-certificates installed and that the time is set correctly
So I thought maybe a network problem… Let’s try to ping google.com and my router’s ip:

root@volumio:/home/pi# ping google.com ping: unknown host google.com root@volumio:/home/pi# ping PING ( 56(84) bytes of data. 64 bytes from icmp_req=1 ttl=64 time=0.583 ms 64 bytes from icmp_req=2 ttl=64 time=0.642 ms 64 bytes from icmp_req=3 ttl=64 time=0.528 ms ^C --- ping statistics --- 3 packets transmitted, 3 received, 0% packet loss, time 2000ms rtt min/avg/max/mdev = 0.528/0.584/0.642/0.050 ms
At this momento you could think I have no internet connection or some values misconfigured, but I’m actually listening VeniceRadio through Webradio@Volumio, so that’s not the problem. Searching on internet I found some people reporting that wrong rpi-date/time could generate problems and I have actually tried to update it using raspi-config and setting the correct time zone, but nothing happens.

Any clue about what is going on?

Thank you so much and regards from Spain!

So silly… Nameserver was the gw, and for some reason my router doesnt provide dns properly.

I have successfully completed rpi-update, but in the end it says GIT needs to be installed. Is that true? I tried apt-get git-core but it says there’s no installation candidate.


You need to do

sudo apt-get update



sudo apt-get install git-core sudo apt-get install binutils

After that sudo rpi-update will work…