RPi B+ WebRadio stations, NAS cannot be added

First, thanks for the fantastic system.

Right out of the box Volumio V 1.5 is running on my Raspberry PI B+ and it worked as I could play many of the WebRadio stations without any problems.

However, I have been unable, using the Web UI to add any internet radio stations that I know work fine on my Win 7 Laptop.
I have tried to use some of the Volumio supplied .pls files that I know work, and simply change the connection string by copying from my Laptop URL dialog and then altering the Title and saving under a new name. They appear in the Browse list and SOME/Not All can be assigned to the play list but none will actually play.

I have tried to add my favorite rtoldies.rad.io/ without any joy. I have also tried a local radio station’s stream again with no success.

Title1=(#1 ) RTOldies

I also have been unable to use the Web UI to attach to my Western Digital NAS or to my Laptop for access to all my MP3’s and wave files.
I have followed the instructions to the letter on this page to get NAS connected without any success: http://volumio.org/forum/problems-mounting-cifs-shares-t158-20.html

While I am a very proficient Assembly Language and VB 6 (and some .net) programmer I know LESS than nothing about Linux and the command line is beyond hieroglyphics to me so a functioning Web UI is imperative.

If Version 1.5 has these Web UI problems as known issues which are to be resolved in the near future, I will simply wait until they work but it is highly unlikely I will be successful with the Linux command line as I cannot get a simple GUI to work.

I am having a similar issue.

Attempting to add a web radio stream through the GUI (Browse > WebRadio, then use the “+” icon at the top-right corner of the screen, enter the name and URL (m3u file) of a web radio station in the dialog boxes, then click Add) – results in a new entry in the list of web radio stations in the GUI, but playing it does not “work” (I get no connection).

When I manually save PLS files to the \volumio\WebRadio folder, the stations do work (mostly).

Not sure what I am doing wrong here!

Given up for the time attempting to get attached to my Western Digital NAS device or my laptop for MP3s and just concentrating on getting the one and only internet radio station I would like to function.

The best I have been able to achieve is to get the station to appear in the Volumio Web UI browser list and in the play list but when that station is selected it will not play. Have done “Update this folder” for this station in the Browser list and a full Re-Boot numerous times.

The Web UI Transport controls Back/Stop/Play/Fwd appear to have the Play icon visible but as soon as I cursor over that play arrow, it immediately changes to a Pause Icon.

The one thing I did notice is using the supplied Absolute70s as a reference file/URL was that I could, on my laptop, just select that URL and it would immediately play on my laptop as one would expect.

HOWEVER, the station which would not play, when that URL is selected, the web site opens on my laptop but I must click on the Flash Player.

Are there stations which are not compatible with the Volumio player because they require such additional selections?

THIS WORKS: :smiley:

Title1=Absolute Radio 70s (High Quality)



Answers in sort of random order:

Of course it doesn’t, thats a link to a webpage not a stream, then the music that play’s uses flash, there is no flash on ARM based devices.
If you got an account you could select “Preferred Player” and then select VLC you might be able to use what that button leads to.

There is a bug in the webui, when adding a radio station it creates an .pls but should be a .m3u. Make sure there is a new line after the url.

Also, take a look at the FAQ: faq-and-the-answers-for-t1545.html

This is a webpage not a stream.

This is a link to an audio stream

The rule of thumb: If you open a link and audio starts playing w/o showing a webpage, you have a working stream.

Thank you very much MobeyDuck that clears up a ton!