RPI B+ and compatibility ?

Hi everyone,

I try to install Volumio on a RPI B+, but when I boot the SD nothing happens, even the network led is off.
Does anyone have a clue or a solution ?
Some help would really be appreciated ! I’m going crazy…

(I’m sorry for my bad English but I’m French…)
Best regards.

I have a raspberry pi b+ and I have never had problems. Be sure that ip address is correct and don’t forget that you have to wait about one minute after switch on.

Which image have you tried? And is the ethernet cable plugged in firmly?
I’ve had times that the ethernet was not plugged in properly, resulting in… well nothing happening :wink:


-Yes the eth cable is properly plugged, but led stays off,
-How can I know the RPI IP adress ? It doesn’t boot at all !
-My Volumio version is 1.55

-My other SD (with a Raspbian) works perfectly ; but with the Volumio SD nothing happens…

It sounds like a compatibility issue, but the volumio image is created for all versions of the pi with the exception of the 3B.
You can use either a ping to ‘volumio’ (without the quotes) on your local network or try to browse to volumio.local with your browser.

If all else fails you could log into your router (or other DHCP server) to check if any IP was assigned to a host with volumio in the name.

Are you also absolutely sure it’s a Rasperry Pi B+? Could you post a picture of the top of the Pi? With the revision number on it.

I have tried Volumio on a B, B+ and 2B, all without problems.

Tx for all,

But I can’t see the RPI IP or browse it threw the router : because it doesn’t boot, the network led is off !
I’m gonna try again.

Hey, I found the solution :
I had to upgrade the firmware, here for those who have the same issue :

/opt/vc/bin/vcgencmd version
==> show the actual version

Then apply this :

sudo apt-get install ca-certificates git-core binutils
sudo wget raw.github.com/Hexxeh/rpi-updat … rpi-update
sudo cp rpi-update /usr/local/bin/rpi-update
sudo chmod +x /usr/local/bin/rpi-update
sudo rpi-update

/opt/vc/bin/vcgencmd version
==> show the new version

Then reboot, everything should be working fine.
==> If you encounter issue accessing Volumio, use directly the RPI IP adress in your browser instead of //volumio.local

Hope that helps !


1 Like

Super! :slight_smile: Thanks for sharing your solution. :wink: