RP3, Volumio2, Synology and remove old mounted network drive

Hi everyone!
I made to connect my Synology NAS with my RP3 with Volumio2 (CIFS, no NFS, and a specific user in Synology with only read permission)


I can’t see the mounted drive (the red bin icon and green edit one), but it works (I can see and listen all my music). I have the same setup in a RP2 and after some reboots I can see all the mounted points in GUI.

I made several mounted, but now I’d like to remove all of them and maintain only one, but… I can’t edit or remove them in GUI. I found all my drives mounted in /var/lib/mpd/music/NAS. Also in /mnt/NAS.

When I try to remove directories with rmdir I have a busy device error. I can do “sudo umount -f *” and “rmdir *” and it works, but when I restart the RP3 all the old drives come back again.

I need to find a way to see the mounted drives, like I do in the RP2 (I can’t understand why it works in RP2 and not in RP3) or a way to remove via terminal the unused drives.


If manually removing the folders from /mnt/NAS doesn’t survive a reboot, then presumably Volumio is remounting the shares when restarted. I don’t know where this is controlled from (others may have more idea), but given that you don’t see an indication in the UI that the shares are mounted anyway, you might consider doing a factory reset or even a re-flash, and try mounting from the UI again.

I tried too to remove the content of /mnt/NAS/. with sudo umount -f and rmdir and it worked, but after reboot they come back again.

I think I’ll do a factory reset.

Thanks!! :slight_smile:

Re-flash and everything working fine!!