reinstall Volumio with ssh?

Is it possible to reinstall or repair my Volumio image using ssh? The case I have is a pain to put together and does not provide access to the SD card. I was messing around with my router and NAS and now the Volumio GUI won’t load. The log file is empty.

I’m able to ssh in and made a backup file. When I type “volumio” I get the commands listed, but when I type them, I get things like this.

“curl: (7) Failed to connect to 127.0.0.1 port 3000: Connection refused”

So if I can do something to reinstall from the command line, that’d be great. Otherwise I’ll tear it apart and reflash it.

Thanks,
Mike

hi,
Remove /data/configuration/system_controller/networkfs/config.json if the problem is just the nas…

rm /data/configuration/system_controller/networkfs/config.json

or
you can create a file in /boot called factory_reset
and reboot

sudo echo >  /boot/factory_reset
reboot

It will do a factory reset. You will lose all your settings !

You will lose all your settings … BUT try the backup/restore plugin :slight_smile: before you do a factory reset.

The factory reset worked great! Thanks balbuze.

I used the tar backup process from chsims (oh – that’s you!!!) elsewhere in the forum. It crashed during the restore, but the GUI worked, so factory reset 2nd time via GUI. I don’t see a backup plugin when I search from within gui. Is there another place to look? My setup isn’t too complicated. So after setting up 5-10 web radio stations, and rescanning my library, I’m good to go.

Oddly, it put me back to 2.175. Some things were weird and it took me a while to check that. Went through the update cycle a couple of time times. Everything seems good now.

Thanks for the help.

Mike

Note: factory-reset takes you back to the originally flashed version, not the previous one!