Raspi 3 B+ does not start with volumio-2.587-2019-06-11...


I am a Raspi user for quite a long time. So I know the main things.
E.g. I am experienced in writing SD cards to setup noobs or kodi.

But I am completely new to volumio and audio players in general.
The plan is to setup a new device that will be my volumio player.
Device is Raspi 3 B+. (Test with noobs -> raspbian is ok, also a Moode image booted)
And HifiBerry DAC+

To keep it simple at first, I connect no screen, no keyboard/mouse, no DAC.
Wifi is onboard.

  1. I write the image to the SD card (volumio-2.587-2019-06-11-pi.img) (I also tried different cards which already worked for Raspi)
  2. I safely remove the card from the PC
  3. I put the card into the Raspi 3 B+
  4. I plug in the power (power supply is original Raspberry with 2.5A)
  5. Red LED gets on
  6. Nothing more happens: No green activity LED flashing, no Wifi access point after 5 minutes or after 5 hours

I also tried with Ethernet cable instead. No connect listed on the router.
There is no live at all and I have been trying since a week without any progress.

Back to a Raspbian SD card is ok again. So I want to conclude that there is no hardware issue.
It seems that this total failure is not usual. Did not find it with Google.

Thanks for your comments!

Well, first off I would check the image integrity by redownloading & comparing the extracted image’s md5 sum with the correct value.

Edit: Also make sure that on the first boot you leave the RPi with uninterrupted power for 5-10 minutes (stuff going on in the background).

Thank you chsims1.

I tried the download three times and made different SD cards.
Only the last download is present on my PC. MD5 check for that image is correct.

After power up of the raspberry I waited more than 5 hours to be sure, that I do not disturb initialization.

I had older raspberry models somewhere. Need to find it first…
I will try to install the image on them and come back to report the result.

So, to summarise, you’ve tried multiple different SD cards, any of which can boot with Raspbian, and none of which can boot with Volumio. My normal response to this sort of game with a Pi is to throw the SD card away and put a new one in, but that doesn’t pertain here (I think). I use Win32DiskImager to write the SD card, having first formatted it with the SDFormatter tool. I think there has to be a flaw somewhere in your writing process but I can’t see it from your description. FWIW, I’m using exactly the same image on a 3B+, albeit with a different DAC, and (annoyingly for you) it just works. The only thought that comes from the description is that you might remove the HFB DAC and see if Volumio boots. If it does, that points to the wall wart going bad, not supporting the additional load of the DAC properly, and time for a new one.

Chris M

Hi chrisrm9208,
I also tested with removed Hifiberry. Same behaviour.

But I have news:
Yesterday I found my older RPi 2. I used one of the same SD cards as I took before, wrote the image again.
Put it in the RPi an power up.
It started to work immediatly. Everything happened as described in instructions.
I configured network, plugins etc. Then shutdown.

Moved the SD card to the RPi 3 B+. It started without any problems.
Installed keyboard configuration tool, and touchscreen plugin. Now I also have a local GUI on 10".
Hifiberry is mounted and configured.
Everything looks nice for now.

But another test failed that worked before. An other card with fresh Raspbian worked some days ago. Now it does not boot on this device any more. On the RPi 2 it does.

So I don’t have a clear evidence, but I doubt that my RPi 3 B+ is bug free.
On the other hand I see, that the image and the sd card are not responsible. Volumio is up and running.

Many thanks for your comments! I will rather exchange the device and in worst case will use the RPi 2.

Same here.
Recently bought a new faster SD card for my Volumio box (Raspberry Pi 3B + Allo Boss DAC) so a couple of days ago I took a Volumio backup, wrote the latest disk image for the Raspberry Pi (volumio-2.598-2019-07-26-pi.img) to the new card with dd, stuck it in the Pi3 and powered on… nothing, left it a while, no ethernet link light or anything. Returned it back to the way it was with the old card in and left it for another day.

Tried again tonight, this time dumping today’s newly released image to the new card (volumio-2.599-2019-08-02-pi.img), again nothing. Took the Pi3 and plugged it into a monitor & keyboard and tried again, nothing, no signal on the monitor even.
Put the same card into a Pi2 connected to the same screen & keyboard, boots fine. It checked the filesystems and expanded the data volume, reboots as normal ready to go.
Shut it down cleanly, put the new card in the Pi 3B again, nothing, zip, nada. Put the old card in again (currently with Volumio upgraded to 2.598 on it), all good.

Seems like there could be something wrong with the few latest images on the Pi3 & 3B+, maybe a bootloader problem?

I am using it now with a PI3B and it works. Do you mind checking the Power Supply?

Wierd, mine are powered by the official 2.5A Raspberry Pi PSUs btw.

To recap the old Volumio card that was first imaged probably about 18 months ago and gone through upgrades since then boots fine on my Pi3/Allo Boss where it normally lives and on my Pi2.
The new, freshly imaged card boots fine on the Pi2 but nothing happens on the Pi3/Allo Boss.

I could also try with my 3B+ (no DAC) but that’ll have to be tomorrow now, getting late.

Okay. Little update, I feel a little stupid as it works now by simply using Etcher to dump the image instead of ‘dd’ & ‘sync’ (Linux) but because you said it works for you I went away and exausted all possibilities but still, I don’t know why…
a) dumped images consistently worked on the Pi2 but not the 3 & 3B+ on Sandisk Ultras
b) got different results with different cards as two Sandisk cards had this problem but some cheap no-name one didn’t.
c) dd is the standard disk dump tool on Linux & Unix and works for all other disk dumping tasks but didn’t work for these images.
I’d always use something like dd if=imagefilename.img of=/dev/sdx bs=4M oflag=nocache and follow up with a sync (just in case before removal)

… but never mind it works now, thanks for your time michelangelo.

I had the exact same symptoms as the first poster on a new RPI4/2 GB and newest Volumio 2.599 with a new UHS-3 rated sd card. I’m new to RPI and Volumio and only a little experience with Linux, so after a week of frustration I solved the problem by just waiting long enough for the first start on a fresh flash of an sd card. :slight_smile: It would be great, if Volumio people could make the ACT led blink while it’s doing it’s thing or something to indicate it’s actually doing something.

PS. I’ve been successfully running Volumio on the new RPI4 with just a 5Vdc 1A power supply (old phone charger) with no extra devices connected yet.