Raspberry Pi and HDMI Sample Rates

Tried everything below, but wifi does not work.
What exactly am I looking for in lsusb and /var/log/message


Not working for me.

Fresh install of volumio.
Start it > follow your procedure step by step.
After reboot I can access to the web page, but unable to add a source. Nothing append.
Some webradio are in the library but when I try to play it, I only have noise (like a radio without antenna).

I’ve got several problems after patching :

  • Unable to add source (menu is n ot responding)
  • Sound 44.1khz and lower are correct, but not higher.
  • DLNA target not working anymore

Rasp 1 B 512Mb

Not tryed the clean install > will do this now.

Any idea ?


It did not work for me. I followed your instructions precisely but it would not boot and stuck on colour gradient screen. Should this be working with a Raspberry Pi 2 Model B? I assume when you say RPi 2 in the instructions it is that I must follow for mine?


Hi Tristan,

For me, Pi1 is any model with 256 or 512MB of memory, it has an ARMv6 core. The Pi2 has 1GB of memory and an ARM v7 core.
It looks like you have selected the wrong kernel, it is quite easy to repair:

  • put the SD card into a Windows or Linux machine and mount the first partition.
  • move the files kernel.img and kernel7.img to the backup directory.
  • rename kernel-SA.img to kernel.img and kernel7-SA.img to kernel7.img
  • in the config.txt file, erase the line “kernel=xxxxx”
  • eject the SD card, put it in the Pi and boot.

With this way the boot code will determine the right kernel to load depending on the architecture.

Thank you for the quick reply Stephane,
I was not that worried as I had made a backup image of the sdcard before attempting this. I will give this all another go this evening. I am pretty sure I selected the correct kernel as instructed, but anything could happen late at night :wink: I also have a RPi1 so maybe if I fail will give that a go.

Hi Stephane,

I managed to get my RPi2 with your mod to boot but all I get best described as major foreground static with almost garbled soft music in the background. On the RPi2 I noticed my DAC disappeared from the dropdown too. Any ideas?

I still have to give it a go on my RPi1 (just have not had time).


That’s bizarre, it works quite well on my Pi2 but the difference from a fresh Volumio install is that I made an ‘apt-get dist-upgrade’.
I have a spare SD card, I’m going to install Volumio 1.55 and apply my mod to see if I have the same behavior as you.
For the DAC disappearing, it’s because the new kernel is not recognized by the PHP scripts. I’m going this afternoon to get the 3.18.5 kernel sources and recompile.

Great, please let me know the outcome!

If someone knows where I can get the 3.18.5+ kernel sources used on Volumio 1.55 … :unamused:

Maybe @michelangelo will help :bulb:

It’s me again with some new files to be tested! Tristan, do you have time to try this setup please?

  • download the files boot-3.18.11+.tgz and modules-3.18.11+.tgz on the Pi in /root (for example)
  • in /boot, make a backup of theses files and directories: .dtb, kernel overlays/ (mkdir backup ; mv kernel* *.dtb overlays/ backup)
  • in /, extract the files from both archives (tar xvzf /root/boot-3.18.11+.tgz ; tar xvzf /root/modules-3.18.11+.tgz)
  • remove any kernel=xxxx entry in config.txt
  • reboot

It is working on both Pi (armv6) and Pi2 (armv7) on a Dell LCD screen (sound limited to 48kHz). I will try tonight at home on my AV amplifier.

The kernel comes from here: github.com/raspberrypi/linux with the config files from the Raspbian kernel source package. No RT patch.

I do not have any I2S DAC so I can’t test if this new kernel works with I2S but I can choose from the dropdown menu a DAC and I can see the module loaded at boot.


Wahooo! I will give them a try tonight and report back. I will give it a go with my I2S DAC too. Thank you.


New kernel and modified HDMI sound driver tested tonight on a Pi1-B and a Pi2-1G without any problem.
I used a 192kHz FLAC and the Denon AVR 1911 AV amplifier switched to the correct clock.

Hi Stephane,

Absolutely awesome, It all works HDMI 192khz out and my I2S IQaudIO DAC works too. Thank you so much.
On first attempt it did not work, so I installed a fresh copy and tried again successfully. Out of interest where are you based? Give me your PayPal address, I think I owe you a beer or coffee or something!


Tristan, you owe me nothing, it only took me time and an account on a multi-processor machine. :wink:
It is my way to say thank you to the Volumio creators. I’m living near Nantes, France.

Here is the modified code for the BCM2835 kernel driver (in kernel_source_path/sound/arm/bcm2835-pcm.c - starting line 26):

.formats = SNDRV_PCM_FMTBIT_U8 | SNDRV_PCM_FMTBIT_S16_LE, .rates = SNDRV_PCM_RATE_CONTINUOUS | SNDRV_PCM_RATE_8000_192000, .rate_min = 8000, .rate_max = 192000,

Hi guys,

Unfortunately, still not working for me.

With these new files, Pi wont boot anymore.

Fresh Volumio Install.

Steps are :

  • Install volumio
  • Delete old files
  • Extract tar
  • Reboot.
    Correct ?

Do I need a specific build of Volumio ?


Sebastien (be)


It’s working !

What I’ve done :

  • Fresh install
  • install update (adb-get)
  • install first “patch”
  • directly install sencond “patch”

Bored to use openelec to listen music in 192khz.

Thanks !!!

Merci mille fois !

How to get to kernel_source_path/sound/arm/bcm2835-pcm.c - ?


It’s in the kernel sources. They are available here: github.com/raspberrypi/linux
Instructions on how to (cross)-compile a kernel are here: github.com/CirrusLogic/rpi-linu … g-the-code