Raspberry Pi and Adafruit LCDPlate

Hi Guys.
This is my instructable blog to get your “Adafruit 16x2 Character LCD + Keypad for Raspberry Pi” working on the VOLUMOI OS.


I have also added some scripts to get all the “di.fm” and “sky.fm” playlists in a nice, organized structure. The ideas are not my own, but added and put together from lots of sources.

I hope this helps


Hi and thank you for this. The code works great. However, I’m having problems getting it to autostart. The method described in your read me does not seem to work in Volumio (at least for me - I always get an error on the last step). I have also tried adding this to cron, but this does not seem to start the script at boot, even though I have (re)enabled cron and other cron jobs do work. I wonder if you could provide some further advice about autostarting this script on boot? Thanks again for your instructions.

I must admit that I am an enormous NOOB. But with a lot off effort (and lists of fail) I managed to get the Adafruit LCD 16X2 Negative to work. After some more effort I got thru the lines mentioned in the thread. And now I have some issues.

I followed the read me.txt, after that the new script does not seem to start until I login (ssh) by terminal and give the command to run ./lcdSongInfo.py. When this runs the web interface does not seem to work properly the time freezes, and it is very slow. The volume works.

So my question is… How do I get it to auto-start and have a functional web interface??

(and yes there sometimes is a minor issue with the lettering, but that is a thing for later).

In most forums the threads mostly contain a question or mentions a fault…thats how it works. But I do want to thank cyber7 for its efforts so far. Being a noob and have a mor or less working LCD display and buttons makes me a very happy man.

Hi there

Am struggling to follow Aubrey’s guide here : aubreykloppers.wordpress.com/20 … t-the-box/ to get my Pi + Volumio working with my PiPlate

I’m running Volume 1.5 on my Pi (Model A with USB Ethernet which is working fine as a Volumio Web Controlled Player to HDMI) However when I follow the guide I get a failure on the sudo apt-get install python-rpi.GPIO line as it can’t find that package in the Volume default repos. I’ve tried editing the repos and failed.

Any guidance? I realise this is an old thread - hope someone can help.

Please paste here the content of your /etc/apt/sources.list file and we’ll sort this out…

Wow - that was quick. Thought it would be something to do with sources… These are what I have. No alterations from standard Volumio 1.5 :

deb http://repo.volumio.org/apt/ jessie main contrib deb http://mirrordirector.raspbian.org/raspbian/ jessie main deb-src http://mirrordirector.raspbian.org/raspbian/ wheezy main

I tried adding non-free rpi etc. to them to no avail. Is it jessie / wheezy thing?

Try just with

deb http://mirrordirector.raspbian.org/raspbian/ jessie main

Do apt-get update before trying to install
Let me know

Tried that michelangelo. Edited sources, apt-get update and the apt-get install python-rpi.gpio

Get :

root@volumio:~# sudo apt-get install python-rpi.gpio Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package python-rpi.gpio E: Couldn't find any package by regex 'python-rpi.gpio'

Same as before.

This is my /etc/apt/sources.list

#deb http://repo.volumio.org/apt/ jessie main contrib #deb http://mirrordirector.raspbian.org/raspbian/ jessie main #deb-src http://mirrordirector.raspbian.org/raspbian/ wheezy main deb http://mirrordirector.raspbian.org/raspbian/ jessie main

So. I started from scratch. Downloaded Volumio 1.5 image, burned to SD card, booted my Pi. Ran rip-config to expand the file system. Checked Volumio worked.

Followed Aubrey’s instructions here : pypi.python.org/pypi/RPi.GPIO/0.5.8 ) But before I did that I thought I’d check all was still good.)

However on reboot Volumio doesn’t appear to be running properly. I get some ‘Illegal instruction’ warnings when Avahi and mpd are started during boot up. When I run top I can see mpd running, but when I try to access the web front end via IP Address I get nothing.

I’m getting the feeling either I’m doing something wrong or there is something in Volumio 1.5 that doesn’t like the latest versions of the packages installed by Aubrey’s instructions ? (Newer packages installed?)

Should I be SSHing in as root, pi or volumio? I’ve been going in as root mainly…

Anyway - I thought I’d carry on just to see if I could install the GPIO stuff this way. I had to apt-get install gcc to be able to install the GPIO stuff. But it seems to be there.

I had to alter : git clone github.com/adafruit/Adafruit-Ra … n-Code.git
to : git clone git://github.com/adafruit/Adafruit-Rasp … n-Code.git
(i.e. change https to git) to get the Adafruit stuff to download. I also logged in as pi rather than root for this bit as it appeared Aubrey’s script needed the python stuff to be in /home/pi not /root

I was then able to - it appears - install the GPIO bits in Python.

However after following the rest of Aubrey’s guide - copying the lcdSongInfo.py into the Adafruit LCDPLate directory, copying start_lcdSongInfo.sh to /etc/init.d and chmod 755ing it I get an error about the start_lcdSongInfo.sh during boot up saying No such file or directory.

I’d really like to get this working - but feel I’m hitting a brick wall. I’m not a total noob - but I’m no expert… Any help really appreciated. Love Volumio - such a nicely designed front-end and it sounds great. Just that I’d really like to get the LCD display working with it - and some front panel buttons!

Think I might try some different SD cards just in case they are causing me issues… These have worked fine for OpenElec etc though.

Hi noggin72, Did you get this working? I’ve just got the LCD plate and I am having similar problems. I was able to run the adafruit example of changing the screen colours but that’s it. I’ll keep working on it but I find with minimal spare time my debugging progress is usually slow.

Hi folks
I got this working great, albeit with a little help from Mobey Duck, on a Model B Rev 2 with Hifiberry Digi. It took me a while to find and change the parameters for my 20x4 LCD.
When the current song on Volumio is stopped, the display only shows on the bottom line the inactive timers - " --:-- ] --:-- "
I was wondering if someone could suggest additional code for the lcdSongInfo.py script to instead show 4 lines of text when there is nothing playing?
I’m afraid my coding skills are zero!

Great forum, and happy new year all!

Edinburgh, Scotland, UK

I got it working. I followed the instructions and changes to instructions in this topic. I found the problem with running start_lcdSongInfo.sh during boot was because the file was saved in dos-format probably my fault. After that it took me awhile to work out I had to adjust the contrast for the text to display. Too lazy to find a screw driver to fit:) When I next find some time I’ll refresh the sd card and document the my steps to get it going. Thanks for everyone’s contributions to this.

I got some time to document my steps. Firstly I started with fresh install of volumio v1.51 and configured it for me.

Here is the process I used to get the ADAfruit LCD to work on my raspberry pi b and b+

I worked out the steps from this forum topic and the following link
aubreykloppers.wordpress.com/20 … t-the-box/

So thanks cyber7, noggin22, michelangelo and everyone else involved in the volumio project.

Step 1.
login to raspberry pi as pi

Step 2.
sudo nano /etc/apt/sources.list

#deb repo.volumio.org/apt/ jessie main contrib
deb mirrordirector.raspbian.org/raspbian/ jessie main
#deb-src mirrordirector.raspbian.org/raspbian/ wheezy main

Step 3.
add at end:
sudo nano /etc/modules


Step 4.
Then install the PiFace libraries:

apt-get update;apt-get install git python-smbus i2c-tools python-dev gcc

git clone git://github.com/adafruit/Adafruit-Rasp … n-Code.git

Step 5.
from aubreykloppers.wordpress.com/20 … t-the-box/

The code available here: dropbox.com/s/iqoyy5lm2tik1 … Script.zip

Follow the steps included in README.txt file…

before rebooting change start_lcdSongInfo.sh to linux format. did this by using nano and the option comes up when saving

Step 6.
don’t forget to adjust contrast.

hope this helps.

I found after adding directories to the library the lcd didn’t work anymore so had to redo
4. Run “sudo update-rc.d start_lcdSongInfo.sh defaults” to add to startup (init) files.

I haven’t investigated this further but should be noted