Raspberry Pi 4 Volumio Not Working Hot Spot Not Appearing on Wireless List

Any clues why Volumio hotspot does not show on boot up?

I’ve got two Windows laptops, a desktop running Ubuntu, an Android and an IoS mobile. Nothing on any of them. With with an Ethernet cable or just by itself. I’ve re-flashed and re-booted umpteen times.

@balbuze I appreciate your help above, but so far nothing has worked.

Far from a 10 minute set up, Volumio has so far given me 20 hours of frustrating trial and error and I’ve made zero progress.

I don’t think the hotspot will show up if you plug in network cable, just connect via ip and perform the setup.

I haven’t tested, but i guess it could be possible that if you had cable plugged when the system booted for first time, it won’t launch the hotspot on successive attempts anymore.

Shutdown the pi.
Plug in network cable.
Power pi.
Use fing or alternative to find the IP address from your home network.
Connect via IP from the browser and finish the setup.

1 Like

Thanks @Joni_Salminen Sorry for the pause in comms - I’ve now got myself a HDMI cable and monitor and can see the script when I boot it up. See photo pasted below.

I don’t understand what is going on - and hoping someone on this board will be able to interpret, eg “start4.elf is not compatible” and “This board requires newer software”. It’s clear it was not reaching first base all along.

To repeat from my posts above - this is a brand new RPi and SD card. I’ve flashed using Balena Etcher and the RPi SD flash on Windows. At the end of the process it ejects the card and says one of the two partitions needs reformatting - I have simply removed the card and inserted it in the RPi, plugged in the Power cable.

image

Sounds like you have the V1.5 version of the Pi4, which does indeed need a new version of the kernel. This is fixed on today’s software update.

Update v3.198

FIXES

  • Latest PI kernel for PI4 1.5 compatibility
1 Like

Oh my…that looks like a problem analysis and a solution! Thanks so much for this.

Just skimmed through the thread Volumio not working on Raspberry Pi 4 rev 1.5 board - start4.elf not compatible - #42 by Bartleby

Up and Running! Thanks all for suggestions and eventual solution. Now on to learning my way around Volumio and enjoying some sounds.

1 Like