Raspberry Pi 4 HDMI Trouble [SOLVED]

Hi,
I got a custom LCD (480x1920) and it works. But I want to get Xrandr work to make some rotation stuff.

But here starts the problem with the message

volumio@volumio:~$ xrandr --addmode HDMI-1 myTFT

xrandr: Failed to get size of gamma for output default
xrandr: cannot find output “HDMI-1”

My config.txt looks like this:
initramfs volumio.initrd
gpu_mem=32
max_usb_current=1
dtparam=audio=o
audio_pwm_mode=2
dtparam=i2c_arm=on
disable_splash=1
hdmi_force_hotplug=1
hdmi_cvt=480 1920 60
hdmi_drive=1
hdmi_mode=87
hdmi_group=2
dtoverlay=vc4-fkms-v3d
include userconfig.txt

It works on RaspberryPi OS .

Any ideas?

If you are using HDMI0 of the Pi 4 you might get along with the Touch Display plugin. You can install it from “Plugins” -> “Search Plugins” -> “Miscellanea”. After that you can set the rotation from the config page of the plugin. Before you reboot comment the line dtoverlay=vc4-fkms-v3d in “/boot/config.txt”

Thanks for that hint. But the config.txt rotation modes doesn’t work on my display I tried everything on RaspberryPi OS.

I installed the Plugin and without the dtoverlay the displays doesn’t work properly. It seems that it switch to another resolution which I can’t identitfy.

What is the brand and exact model name of the display?

It’s a cheap china thing from alibaba. I needed a very special size for my project

Do have a link at least?

Instead of re-adding the dtoverlay you may try to add the following lines to “/boot/config.txt”:

max_framebuffer_width=1920
max_framebuffer_height=1920
framebuffer_width=1920
framebuffer_height=480

According to your values for “hdmi_cvt” you may have to swap the values for “framebuffer_width” and “framebuffer_height”.

1 Like

it only reduced the height of displayed content to 480 but it doesn’t rotate

https://www.alibaba.com/product-detail/8-8inch-bar-display-with-driver_1600174092270.html?spm=a2700.wholesale.deiletai6.48.2e6565655gMtOa&bypass=true

Please post the output of

cat /boot/config.txt

and

cat /boot/userconfig.txt

with the touch display plugin enabled.

Do you use the display in portait or landscape mode?

initramfs volumio.initrd
gpu_mem=32
max_usb_current=1
dtparam=audio=on
audio_pwm_mode=2
dtparam=i2c_arm=on
disable_splash=1
hdmi_force_hotplug=1

hdmi_cvt=480 1920 60
hdmi_drive=1
hdmi_mode=87
hdmi_group=2
#dtoverlay=vc4-fkms-v3d

max_framebuffer_width=1920
max_framebuffer_height=1920
framebuffer_width=1920
framebuffer_height=480

include userconfig.txt

Userconfig is empty:

# Add your custom config.txt options to this file, which will be preserved during updates

It’s a bit confusing. the Native mode of this thing is portrait mode (I didn’t read the specs carefully) but I want it in landscape

That doesn’t show any rotation setting. Has a rotation other then 0 deg. been set on the plugin’s config page?

1 Like

The display seems to be similar to the one used in the thead "DIY streamer with volumio in standard 43cm box - #2 by lausiv.

Maybe have a look at the settings in the “userconfig.txt” which has been posted over there and try out the values from that file in your “/boot/config.txt” (apart from “display_rotate=1”).

IT WORKS!!!

You made my day!

I spent several hours and you made in just a few minutes.

I think the framebuffer does the trick because now the display=rotate=1 works!

Great!

What does your “/boot/config.txt” look now?

Are you able to rotate using the touch display plugin?

my config is untouched but the plugin changed my userconfig:

#### Touch Display rotation setting below: do not alter ####

display_lcd_rotate=1
display_hdmi_rotate=1

I never get this config to work on rasperrypi OS so I focused on Xrandr

Good!

Now let me suggest to move the lines

hdmi_cvt=480 1920 60
hdmi_drive=1
hdmi_mode=87
hdmi_group=2

max_framebuffer_width=1920
max_framebuffer_height=1920
framebuffer_width=1920
framebuffer_height=480

from “/boot/config.txt” to “/boot/userconfig.txt”.

This has the advantage that your own entries remain untouched when Volumio gets updated. In contrast /boot/config.txt file gets overwritten (further information).

1 Like

thanks!

I will do so. Finally I can go on with my project :slightly_smiling_face: