Raspberry PI 3, Hifiberry DACplus and Volumio 2 no sound

I’m using a PI3 with the volumio-2.001-2016-10-15-pi.img image with a Hifiberry DAC +.

I have got the same issues as described here: https://volumio.org/forum/hifiberry-dac-sound-t4769.html, But after editing /etc/config.txt and rebooting the PI, the UI shows Hifiberry DAC Plus as Output Device and DAC model. But I still can not configure the mixer control and mixer control name, the Combo box just disapears, when clicking it.

If I try to play a mp3, I get 5 times the error message: Error: failed to open audio output.

I found this: https://github.com/volumio/Volumio2/issues/615, but my /etc/modules already hat this entry.

I tried also this: https://support.hifiberry.com/hc/en-us/articles/205377651-Configuring-Linux-4-x-or-higher, but after removing the line dtparam=audio=on, aplay -l did not found any sound card at all.

I found the topics https://volumio.org/forum/hifiberry-digi-not-working-with-new-volumio-t4961.html and other, but no solution :cry:

Just to see my Hifiberry is working, I tested it with this test image https://www.hifiberry.com/build/documentation/sd-card-images/, but it worked only on a PI2. So my Hifiberry card seems to be ok.

Any idea, what I can do to get it running ?

You don’t need to edit enything manually to make hifiberry work.

So, do this:

  • do a factory reset
  • once started, go to playback options, enable i2s dac and select hifiberry dac +
  • click save


let me know how it goes

Hi michelangelo,

thanks for you help.

I did the factory reset, selected hifiberry dac + and save. But I still got the red Error: “failed to open audio output.”

In playback options, the Output device shows “Value not found between select options!”.

Beeing sure, I wrote the volumio image again on the SD Card and tried again - same result.

Thanks in advance,

I have got it running, but only with an Raspberry PI 2! Hifiberry DAC+ has been recognized automatically without any configuration.

Is there a compatibility issue with Raspberry PI3 ?

I tried another PI3 - and it works.

Seems there are some GPIO’s on my first PI3 broken…

Hi all.

I’m new in this world of Raspberry-Volumio and I don’t have experience.
I installed Volumio 2 v. 2.118 on Raspberry Pi3 with Hifiberry Dac +.
After set I2S interface like Hifiberry Dac+ it has been recognized bat by starting a song it get me the error " failed to open audio output".
I try to set Hifiberry Dac and works fine until reboot; after it get same error.
I also tried to set a general I2S dac interface and works ok even if I reboot the sistem, bat is not logical.
Someone have a suggestion?