Raspberry Pi 2 HiFiBerry DAC "No Soul"

I got myself a Raspberry Pi 2 the other week and after reading that the audio wasn’t up to much i was pleasantly surprised to what i was hearing from a little £30 box when using with a Yamaha A-S500 Amp and JPW Sonata Speakers, the sound was a little closed in plus a little low in volume but it still put a smile on my face that the little box had a voice

Well the other day i decided to buy a HiFiBerry DAC and after spending the last 3 days listening to my music with the HiFiBerry DAC installed which ranges from Loose Ends, Let Em Riot, BLSHS, Trevor Something, 80’s Electro and Acid House it did open up the music giving it a larger sound stage plus it now matches my other devices volume wise i just find my music is now devoid of any soul plus find the high notes to be very brittle

I own the RPi B+ with HifiBerry DAC+ and I am quite happy.

Maybe things sounds too analytic, maybe you are used to a specific sound (vinyl) ?

What kind of digital files are you feeding it and how ?


I just find there’s no warmth to the sound which you get when just using the audio out from the Pi, i do like my vinyl with my Rega :slight_smile: but also happy playing CD’s with a Rotel 965bx

Get most of my digital music off Bandcamp

Try ripping a CD to uncompressed FLAC or ALAC, copy the files over and play them locally.

If you have a DAC+ make sure the hardware volume control in a bit below 100, like 90 or 95, in order not to overdrive the rest of your system.

I removed the HiFiBerry DAC last night and going back to just using the Pi’s audio is like night and day to my ears i just prefer the more rounded sound, may go all out and buy a Meridian Explorer 2 just trying to find somewhere to borrow one before i buy plus it will be nice to say i own some Meridian HiFi :slight_smile:

hello, i disagree, i have the hifiberrt dac + on pi b+ and the sound is outstanding, i ve compared to dacs that cost more than 1000 dolars. i think you should try another interconnects… since in my system… some of them give a treble a boost and that is not pleasing.
the hifiberry is super transparent.
the sound of the raspberry is smooth but don´t have enough gain

Been using Kimber Kable - PBJ for years on my hifi but cables can only give you a slight tweak but never change the overall sound of a system

Anyway i got myself a Meridian Explorer 2 DAC the other week which with a Pi 2 and Volumio is a marriage made in heaven :slight_smile:

Could it be the Hifiberry dac + works better with the “older” Pi b+ hardware?

I did exactly the same thing. I installed Volumio on a old Raspberry Pi and ran it through HDMI to my Sony AV Receiver and was way impressed. So I thought that I would buy into the DAC hype in the hope that I would get via I2S something higher than 48khz out of the RPi and therefore better sound quality.

To achieve this, I had to buy a newer RPi (RPi 2 model B) and a IQaudIO Pi-DAC+ HAT with case, and unfortunately was very disappointed. The sound from the HDMI is so much crisper in the mid-range with way more spacial staging even at 48khz.

I even setup both RPis together into the receiver, hit play on the same file from my NAS and flipped between the analogue and HDMI inputs. The HDMI won hands down, even my uninterested wife blind-tested chose the HDMI immediately over the DAC.

On a quest to break the 48khz out of Volumio I have recently purchased and setup a Beaglebone Black but unfortunately that too is only outputting 48khz and much higher sample rate audio files.

Bit perfect debate aside, what sounds better and clearer is what I want, HDMI sounds better (not just for me). Hopefully someone can help with the 48khz barrier on Volumio. For now, I am staying on HDMI.


Hi Tristan,
I have a kernel that breaks the 48kHz barrier on HDMI, do a search on my posts and you will find the thread.

Thank you Stephane, very much appreciated. I have been querying this everywhere. I will give it a go this weekend and report back.

Besides bit perfect you say (why than the ‘quest’ to brake 48khz limit?), the real warmth/soul of your audio is given to the digital signal by the quality/characterristics of your DAC. Used sample rate is a small factor in this. It is likely that your the DAC inside your Sony Receiver performs better than IQaudio. Sure, the way the digital signal is send to the DAC can make a difference (I2S, HDMI, COAX SPDIF) and the sample rate as well (but upsampling seldom improves the original, hence bit-perfect usually performs better). Try listening to a better/hifi DAC connected to the RPi (over USB or SPDIF) to experience even more soul and than decide what works for your situation.

I guess this will give you more than trying to break the 48khz limit of HDMI :slight_smile:

Good luck.

Typically I agreed with this up front, however I then discovered that it was worse with Volumio installed. I have tried two other type of audio distribution with the setup (DAC+Pro) and Volumio was the worst. I did not expect there to be very much difference at all, however there was.

Volumio was sort of sharp, tinny and little bass coming through, very much less depth to the sound, putting even PiCorePlayer on (which is not lossless and all that, but does support 24 bit etc), I found myself leaving it on as it just sounded better.

However, I ended up purchasing Roon (not to be confused with Rune which is different). It too, sounds better than Volumio. I would say it’s along the lines of PiCorePlayer except they do have all the lossless transports etc as well. I have a suspicion it could be to do with a filter but can’t be sure.

Architecturally, Roon is a thing of beauty, the way it connects to devices, and of course their browsing experience is the real winner.

Anyway, I thought I’d post this here so that a) Others might be able to comment and b) Volumio guys might be able to confirm or deny and resolve whatever it is.

So my take is this is not specific to the hardware, it’s specific to the software. Though I still kinda wish I’d gotten a mambo berry instead.

Hi, I’m extremely curious to understand why you had such results, I don’t doubt your listening impressions. And of course it seems weird to me, as we optimized everything to sound as good as possible…
So let’s find out what happens:

  • Could you please share a screenshot of your playback options page?
  • Could you please paste here your mpd.conf ?
  • Could you try on the other OSes to launch the command
    uname -a
    and paste here the result?

Let me know