Raspberry Beta3

just noticed that a new Raspberry Beta is available, thanks for that. it installs fine so far, but with the PiDac the volume does not work out of the Box, in mpd.log are errors like



If you change


in /etc/mpd.conf it works.


People with i2s Dacs, could you please tell how your mixer works?
And other feedbacks as well…

No Problem, I will give it a try in my HiFiBerry Pi later, I’m waiting for the database update to finish, takes some time to suck some 80k files in…

two more things I’ve noticed…

  • the alsamixer volume setting doesn’t translate well into the volumio volume setting, eg. 23 in alsamixer is 64 in volumio, which means that somewhere at 70 volumio starts to have an audible impact on the volume (you can see this when you open a terminal with alsamixerr running and then change volume in volumio or vice versa, the other side always follows)

  • after volume 100 volumio sends always +1 (101, 102, 103,…) to mpd when you click the up button, which makes no sense, 100 is maximum, this is not a motörhead amp :wink:

(I run this as mixer_type hardware btw)


So, there seems to be a new release dated April 25th. Is there a changelog?

Also, is there a way to upgrade Volumio to 1.3 without losing customizations I made?

Thanks, keep up the great work!

Michelangelo, as mentioned in the DAC forum previously - for IQaudIO.com Pi-DAC volume can be made to work in Volumio by modifying /etc/mpd.conf…

IQaudIO.com Pi-DAC doc - including volume settings are here:
iqaudio.com/wp-content/uploads/2 … IO_Doc.pdf

If you would like volume control then edit /etc/mpd.conf to address the correct mixer control of the IQaudIO.com Pi-DAC have the following in audio_output section…

audio_output {

             type           "alsa"
             name           "Output"
             device         "hw:0,0"
             mixer_control  "Playback Digital"
             mixer_device   "hw:0"
             mixer_index    "0"
             dsd_usb        "yes"




Yeah, already said that, but in the second incarnation of beta3 it’s still PCM :neutral_face: