Raspberry 3 & Volumio: Wifi issue

Hi there,

I got Volumio running on a Raspberry 3 with the Hifiberry DAC+
Unfortunately, it is only working with Ethernet, I can’t connect to my Wifi; I also have another SD card with the latest version of Jessie, Wifi works like a charm with that.

the Volumio web application and iwlist (when I SSH) show my neighbor’s networks, but not mine.

I tried a couple of things, changing WPA supplicant config file, changing the interfaces file, changing from DHCP to static and back, but with no success so far.

Could it be connected with the “Volumio Hotspot”? That one seems to be up and running…

Is your network running 5ghz wifi?

Raspberry has only a 2.4ghz capabilities and will show only these networks, could be the case.

Thx for the idea. The router tells me both is running.

I didn’t see that another SD card works fine with Jessie.

If it’s running on both frequencies it should work, maybe the driver is different. Can’t help much, I only used has a hotspot, never as a client

well, tried a new install - no success
edited the wireless.js file to stop Volumio’s hotspot - hotspot not there, but also no influence on my wifi

changed my wifi’s SSID (it normally has a “_” inside) - no success
changed security from WPA2 to nothing - no success
created a guest network, also no security, different name - no success

scanning with iwlist and the installed wicd-curses does give me a couple of networks, but never mine… strange

I’m no expert, but when I was having trouble setting up a few weeks ago, I tried few things. I think what finally did it was switching my router from hidden to broadcasting.


The router has already a visible SSID, it is not hidden.

After a couple of additional Hours of online research I rebooted the router - no success.

I reinstalled Volumio / made a new SD for the third time - no success.

Situation is getting really annoying.

Solved it. This link has the info in it:
raspberrypi.org/forums/view … 8&t=138312

My wifi was broadcasting at Channel 13.
It seems that an older version of raspbian was having issues with 12 and 13.
It was changed there, but Volumio seems to use the old core(?)
Anyway, changed it to Channel 8 and found it through volumio

Nice find, that was a tricky one indeed, thanks for sharing