Rasp Pi 3B - Will only boot with 3.073

Hey all,

Volumio Version: 2.882 and backward versions
Hardware: Raspberry Pi 3B
DAC: HifiBerry Digi-Pro

I cannot for the life of me get Volumio to boot and load with any other version than 3.073, whenever I use any older version I’ll flash it to the card, turn on the Pi get one green light flash then nothing at all.

However with 3.073 works a treat every time, no problem booting or restarting, recognises the Hifiberry hat and any connected media. However, I’d quite like access to the plugins for Spotify connect so want to get an older version working.

The current workflow for any older version is as such:

  • Clean card and create a partition using Diskpart
  • Use Etcher in flash 2.882, 2.878 or 2.873
  • Card into Pi, power up (checked PSU no under-voltage warning)
  • Activity light flashes once then nothing
  • Screen shows no activity

Having run through the previous posts with similar issues I’ve tried most of the workarounds they suggest but with no luck. For sake of sanity, I have just redownloaded a fresh 2.882 gone through the whole process as exactly as instructed in the manual and no luck sadly.

I’m at a loss as to why 3.073 works no issue but any other will not install whatsoever so greatly apprecaite any help!


oke did you try formating it on a pc fat32
use Etcher on the pc…burn it… ignore the format boxes use the X to close them,
after it all take it to your pi and let it boot …

Cheers for the reply.

Tried that no luck sadly, did the following:

  • Diskpart clean then create partition
  • Disk manager format FAT32
  • Etcher to flash 2.882
  • Power up - same result single green half second light then nothing


To add some info:

  • Tried with no hat or ethernet and various combos - No luck
  • Tried some other PSU’s and cables - No luck
  • Raspbian loads fine

Long shot – but can you check the MD5 hash that the downloads of the older version are all good?


Sorry for the delay was away, checked the sum and all good there.

Interestingly I do manage to get it to boot sometimes, usually after 3/4 attempts with at least 30 mins before.

Two of the PSU’s I was trying were triggering undervoltage warnings, with a better supply I can get occasional boots. However, as soon as I try and boot with the HifiBerry Digi Pro hat on no luck, will never boot.

So I think it might be something to do with power requirements, do we know if there’s any difference about how 2.882 and 3.073 handle power?