random pops/clicks when play music through xmos usb-spdif

hardware is raspberrypi model B
tried each kernel profile and still got pops
don’t know what’s the matter.

btw: under same situation but use runeaudio with the same xmos usb-spdif and play the same track , it works flawless! but unfortunately runeaudio doesn’t support upnp which volumio support well!!
hope in the future version xmos will be better supported


You are not alone. See this post:-


the only difference i know from my level is: volumio is based on rasbian, and runeaudio is based on archlinux

You could be right who knows :question:

I’ve noticed that one is green and one is blue :smiley:

We’ll see if someone from Volumio Team can explain this. Fingers crossed.

I confirm Back to Back with same 24bit/96kHz AIFF file and Network Loading. Playback from same NAS Mount.

RPi Model B + Volumio 1.4 + Audilab Q-DAC : Get regulars pops & clicks

RPi Model B + RuneAudio 0.3 + Audilab Q-DAC : Clean

michelangelo may explain this (i hope)

thats my job (and maybe a little bit more)

Thanks for the reply joda.

I found connecting volumio on my cubox-i 4 to my rega dac via optical spdif (with physically attached USB stick drive) everything worked fine. Though I would get pops and noises between tracks. Over wifi playing from nas over 16/44 became gappy.

When I added an xmos x20 spdif /usb converter I got pops and clicks over wifi at all resolutions - But none from attached usb drive. And the sound was improved hugely. But when I started to use Bubble upnp as the player, rendered to volumio a) the pops and clicks went away, Even the between track ones. and b) it happily played everything gaplessly over wifi up to 24/192.

I think therefore the xmos is a lot more demanding in terms of needing a perfect bit stream from volumio/cubox than cubox is using it’s own audio circuits. As the converter has no OS to make up for the shortfalls in the delivery and as it is asynchronously taking the bit stream straight from volumio/cubox main processor and usb output.

Now bear in mind that cubox-i4 is quad-core at 1ghz and has 2gb ram. So I’m running a 16MB buffer at 30% The usb converter is taking the signal straight from cubox-i’s main processor, through the usb out, setting up a presumablly very demanding feedback loop on the processor, to regulate the flow of data; remember It’s bypassing the cubox audio circuits completely, then clocking the signal, and then delivering it to the dac. If the main processor of your hardware can’t handle the demanding spdif usb converters requests for whatever reason software or hardware, you’ll get interference in the form of pops and clicks.

Now in order for the main processor to get a bit perfect signal the file has either to be stored locally or delivered through the wifi chip (in my case) via bubble upnp which ensures a much better traffic flow from the nas, than volumio can manage on it’s own.

So at each stage I am letting the core functionality of each specific part of the chain do what it does best, and moving other functionality to another software of hardware component to get the best possible output.

Here is a good guide to USB audio.