Random ALSA error

Volumio 3 Issues?

Hi, I’m experiencing this strange issue: i install volumio (rasp PI 2B + iqaudio pro) and everything is ok, i can play music both from rca connetor and 3.5 headphone jack.
As i try to play something, after volumio has been turned off an than turned on again, i am no longer able to play anything and i have this strange error message:
“failed to open “alsa” (alsa); Failed to open ALSA device “Volumio”: no such device”
Can someone please help me understanding what’s wrong?

Details please. Do you mean that Volumio has been shut down, and that at some time later you boot up, try to play something, and get the error message? Does the error persist if you try to play other sources?

Yes, exactly like that. It persists if i try to play other sources… the only way to have it fully functional again is to reinstall. I have already experienced that four times, with different SD too.

1 Like

Please reboot, try to play something, and then post the link to the system log here please.

Would you share some system logs please?

1 Like

I’ll try, but actually i don’t know how to get a system log. :grimacing:

Just read and follow the link given by @chsims1

Opss… :smile:
I need to reassemble rasb and dac and than i’ll try to recreate the error message.
Coming soon…

I have new info and evidences abut my issue: i forgot to say that i have also installed the remote pi board. I realized that everything is ok until i install and activate the remotePi official plugin, after that i start experiencing the ALSA error.
Here is the log file Log


1 Like

Your log shows you’re having a GPIO conflict:

Jan 23 13:31:22 volumio kernel: pinctrl-bcm2835 3f200000.gpio: pin gpio18 already requested by ir-receiver@12; cannot claim for 3f203000.i2s
Jan 23 13:31:22 volumio kernel: pinctrl-bcm2835 3f200000.gpio: pin-18 (3f203000.i2s) status -22
Jan 23 13:31:22 volumio kernel: pinctrl-bcm2835 3f200000.gpio: could not request pin 18 (gpio18) from group gpio18  on device pinctrl-bcm2835

The RemotePi board uses GPIO 18 by default for its IR receiver. The IQaudio DAC Pro uses GPIO 18, too.

So make sure you have the RemotePi board (i.e. the PCB) modified to use GPIO 17 and set the option “Use GPIO port 17 for IR receiver” to “on” on the config page of the RemotePi plugin.

Ok, i really thank you. I thought i only had to install the official plugin to have the remotepi properly installed an working.
Now… can you please tell me how to modify the page of the RemotePi plugin? I’m not used to these kind of fine tunings. Thanks

You first have to modify the PCB i.e. the RemotePi board itself. It is described in the first link I gave you in my previous post: Support for RemotePi Board for Pi 4, RemotePi Board for Pi 3 B+, Pi 3, – MSL Digital Solutions (look for the header “Changing the GPIO port for the RemotePi Board IR Receiver from 18 to 17”). :wink:

Then open the plugin store, select the tab “Installed Plugins” and click on “Settings” of the RemotePi plugin. Set the option “Use GPIO port 17 for IR receiver” to “on”. A reboot will be required.

ok, got it… but i see that i’m supposed to solder a trace!!! :scream: :joy: :weary:

1 Like

Soldering is only required for PCB hardware revision 1.4.

if i’m not wrong (and i hope so) i need to solder even with PCB hardware revision 1.6 and higher:
“The newer hardware revision 1.6 of the RemotePi Board makes the process a bit easier. The copper trace leading to GPIO 18 still has to be interrupted. Then the two normally open pads need to be soldered together, this will connect GPIO 17 to the internal components. Please refer to the pictures below.”

1 Like

Yep, you’re right!

now i only need to find a friend with soldering skill :grimacing: :smile:
I really thank you, i would have never solved it without your help… i was sure it was a sw issue.

Unfortunately I had to uncheck the solution box. I soldered the two open pads as required and than i decided to completely remove the pin n.12 (GPIO18) instead of completely removing the copper trace wich starts from there. I thought the result would have been the same (avoiding to break the board) but when i plug the power Rasp doesnt turns on.
Why is my solution wrong? Looking at the board a cannot see any difference between removing the pin and cutting the trace.
Thanks for any contribution or suggestion
May be i should change the topic title