RadioParadise plugin Flac, works only for a while.

Hello, this issue was already raised in another post, the fact is that Marco, the author of the plugin, gives it as solved with a change of index.js.
I made the index.js change but there is no mode. It works between 5 to 30 minutes and the sound is cut off but it keeps refreshing the metadata. He does it in two different devices that I have running in my house, (both Rasp3, one with DragonFly, another with AlloBoss and different versions of Volumio, one with the latest beta).
Is someone else having this problem? Can you verify that it works correctly?
I will thank you.

Can someone please test this?
It’s just about installing the RadioParadise plugin and testing whether the Flac broadcast remains stable.
Thank you

I gave up with the flac feed for radio paradise via volumio it is not and and has not been stable for months i have all the symptoms you describe and more the RP flac feed causes the error light on my dac to flash repeatedly as the feed breaks up and then shuts down sometimes it restarts by itself most of the time it does not.
320kbps is more stable but also has had it’s issue’s in the past.
I have read continually this forum for a fix but there does not seem to be one and various threads on the same subject all seem unanswered or at least no permanent fix.
I have has better success with the flac feed on Logitech Media Server.

Thanks Digitalius, if it works in LMS we rule out that the problem is RadioParadise, as far as I know, both plugins work similar, download the metadata, the duration of the themes and the download site, with that they synchronize the broadcast.
The strange thing is that for me it worked correctly until about two months ago, it is unlikely then that it is a problem of the plugin, will it be a problem of the latest versions of Volumio?
Let’s change the question, does someone work correctly with RadioParadise plugin in Flac mode? What version of Volumio are you using?

very welcome danielfelix. :smiley:
I am currently using volumio vers 2.411 as i read someplace that all volumio versions past 2.444 had bugs in the system so i decided to start at 2.411 and see if i could find the differences if any between the versions.I dont think it is a problem with the newest version alone
I have upgraded on a different RPI unit using volumio to the latest vers from mid last year and the same problem happens on all versions i have used .
LMS not currently running on my system the server box is down for an upgrade i will have it back online soon.

In the LMS Squezzbox forum they also report the same error:
Evident that the error is RadioParadise, something has changed, I see reporting directly in RP.


I can report to have no problem with the Radio Paradise Plugin in FLAC format. I just tested with v2.389 and v2.452 on another PI, i then upgraded to 2.526 - it is running without any interruption since more than an hour now on both.
The first Test-PI is a PI2 - the other a PI3b (not +) both connected via WiFi. (edimax usb and the other onboard)

Could it be there is a problem depending on where you are located, what ISP you have or what hour of the day you try to get the service.
I’m located in Germany / Bavaria and my typical listening / testing hours are from 7 PM to 10 PM. (CET time zone) It’s really working totally stable for me.

I will test again tomorrow and for the rest of the week to see if i can also have the issue.

Best Regards and hope it will work also for you soon again - but it seems to be no issue of the plugin.
I didn’t test RP over LMS.


Can also confirm its running fine here, listen to about 2hrs every evening.
I have a few customisations for the different channels, (mellow mainly) running on a self built version of Volumio based on:


As I already mentioned in the plugin thread, it’s running for hours here without a problem (Pi Zero W with HiFi Berry DAC and the latest Volumio 2.522).

The RP API and the plugin basically work like this:
You get one flac file which contains up to 7 or 8 songs, so the result of the api is one flac url and the additional metadata for all the songs inside this one flac file (=name of each song, artist, length, etc.). Here’s an example:
As you can already see looking at the url, this one flac file contains seven songs (1798613-1798619). Actually in this exact case there are six songs and a spoken part at the end with id 1798619. You can play this whole flac file manually e.g. using VLC or even on your Pi. Be aware that it won’t work without the “?src=alexa” url parameter at the end though.

So all that my plugin does is extracting the metadata, start playing the flac file (=first song) and then it’s setting a simple timer with the length of the first song in order to switch the song metadata when the second song starts - still inside this same one flac file. Then there will be a new timer with the length of the second song and so on… While a timer is running, the plugin does nothing but sleeping. Now as soon as the last song of the first flac file starts, the plugin asks the RP API for the next flac file (incl. its metadata). Then it will start from the beginning and so on.

What this means:
In the meantime the plugin is doing nothing but sleeping until the next song starts. After each sleep it’s refreshing the song metadata in the ui with the already pre-cached songs but Volumio/MPD just keeps playing this same flac file (!). Think of this as two independent processes: on the one hand volumio that just plays one file all the time and while this is happening a completely independent task updates the metadata in the ui during this playback. There is absolutely no communication with Radio Paradise except of course for this flac stream that is currently running. So if your playback stops in the middle of a song then the only possible reasons are either:

  • the connection to the stream is somehow lost/broken
  • a bug in volumio/mpd

Be aware that Volumio/MPD just streams the flac file, it is not downloaded completely beforehand so a stable internet connection is needed during the whole listening process. If the connection breaks, the stream will stop after a certain cache limit is reached (probably some seconds of playback).

If you look inside the log files of volumio (ssh and then “sudo journalctl -f”) you can see how many songs there are inside one api event. You can see an output like this one:

[RadioParadise] received new event with id 1798613 containing 6 songs.

and then

[RadioParadise] set to consume mode, adding url:

For Volumio/MPD it looks like this is one single file/song/playlist item even though there are 6 songs inside!

I just submitted a pull request for a bugfix update but this update won’t fix the situation you described if the stream is interrupted in the middle of a song. Because I don’t have this problem and can’t reproduce it.

What about using something different than mpd to play the stream (like aplay or something) so this way you’ll get a notification if\when the stream stops

I have no idea how to do that with Volumio. Do you have an example/snippet? Then I could try to change it accordingly. Even though I’m pretty unsure if this would change anything concerning the broken stream. But maybe it’s worth a try.

I think a simple aplay command can do the trick…

They commented that the problem could be some problem in the internet connection.
It occurred to me to ping the IP of RadioParadise,, and it worked correctly all the time, even though in Volumio the broadcast was cut.
Is this test valid?


Please try the following:

Ok, let’s see:
0:00 1st song
3:30 2nd song
7:18 3rd song
11:47 4th song
16:58 5th song
18:52 abrupt cut in the middle of the song and start from the beginning.

In another test it restarts at 10:37.

Can you draw any conclusion?

Obviously it has nothing to do with the plugin!

I guess it‘s your internet connection or provider. You could try the same with another PC/Mac and see if it works there in order to verify that it‘s not related to your Pi or Volumio. Just open the URL with VLC for example.

Another possible try: Is your Pi connected by WiFi or ethernet cable? If it‘s WiFi then disable it for testing and try it with an ethernet cable connection.

Connected only with the network cable is also cut.
On Monday, the company that provides me internet changes my modem and connects me to 50M.
We tried later.
Thank you very much Marco!

There is no way. Today I changed the modem, I have new connection to 25Mbs, and RP is still cutting as I have been reporting.
I do not find before or now with this new connection, something that works badly with the internet. All applications, other stream services, work correctly.
I am willing to try whatever seems necessary.


There are many reasons that could provoke this. One of which might be the RP server itself.
IMHO the plugin should be more resilient to connection cuts. I can help find ideas if needed

To know the status of my connection, it only occurs to me to ping the radioparadise server, if there is another method they inform me and I try it.
Anyway, everything works correctly with the other services that use the internet, in fact I do not have any problem with other Radios in Volumio.
I always have strange problems …