Radio stream freezes MPD

Hi, I would like to listen Wefunk radio, my favourite radio stream but MPD freezes every time I load the .pls file from the webradio folder.


It freezes also when I load only the stream address from MpDroid, I need to restart MPD. More strange that after I click on the playlist MPD plays the stream for less than a second before the error. I tried to edit the .pls in every way, removing and adding lines but no success.

Running Volumio 1.41 on a RPi B. Other streams play without problems and this specific .pls is ok in every other player. Thanks in advance.

This could be related to a bug in MPD, that seems solved now : … h=v0.18.13

What can you do to solve? Or wait for new volumio version or install newer mpd…

nano /etc/apt/sources.list

change wheezy to jessie

apt-get update apt-get install mpd

Let me know if this fixes

mpd is already the newest version.
mpd --version
Music Player Daemon 0.18.12

The new version isn’t in the repo yet?

Updated mpd to 0.18.14 but the same issue occured.

Anybody can reproduce the error with this specific stream?

The same at me.

Very often - after streaming WebRadio station - MPD freezes; I must restart service.

Try “Jazz” category and “ Global Radio - The Worlds…” and test it for a while. Start, listen, stop, etc… After some times (several minutes) MPD stops work.

I use Volumio 2 with MPD 0.19.19 ver. The same problem with RPI 1 and RPI 3

Any suggest to fix this problem?