[R-Pi B+] Volumio 1.55 and USB iMic: too many basses

On Volumio 1.51 and prior I always had to log into SSH and go to the mpd settings to change the volume operated by the GUI from “Bass Boost” to “PCM” because ALSA lists Bass Boost before the actual volume and Volumio was picking up that one (that is why I asked for a setting on the preferences…).

Once done that modification, everything was fine and the GUI was changing the actual HW volume of the iMix USB soundcard.

On 1.55 I did the same, but the resulting sound has WAY too many basses. I checked with alsamixer and the Bass Boost is set to zero (and if I increase it I hear some more basses…) but the zero setting is different than before.

What can I do? the balance is totally wrong and my room (at standard volume) now vibrates when I play some of the songs…

Should I go back to 1.51 as solution? (I tried no other versions between 1.51 and 1.55).


I have the same situation.

I have a setup with an Nubert Nupro A-20 Speaker directly connected via USB as sound card.


after a clean install of volume 1.55 and if I use the USB DAC from Nubert A-20 connected via USB the volume knop in the Volumio Web Front End regulates the bass level but not the volume level as expected.

My Resolution so far for the “Volume Knob Problem”:

Change /etc/mpd.conf --> mixer_control to “PCM”

[code]audio_output {

type “alsa”
name “Output”
device “hw:0,0”
mixer_control “PCM”
mixer_device “hw:0”
mixer_index “0”
dop “no”


Additional Information:

root@volumio:/etc# aplay --list-devices **** List of PLAYBACK Hardware Devices **** card 0: Codec [Micronas USB Codec], device 0: USB Audio [USB Audio] Subdevices: 0/1 Subdevice #0: subdevice #0 card 1: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA] Subdevices: 8/8 Subdevice #0: subdevice #0 Subdevice #1: subdevice #1 Subdevice #2: subdevice #2 Subdevice #3: subdevice #3 Subdevice #4: subdevice #4 Subdevice #5: subdevice #5 Subdevice #6: subdevice #6 Subdevice #7: subdevice #7 card 1: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI] Subdevices: 1/1 Subdevice #0: subdevice #0

Remaining Problem:

after rebooting the raspberry the sound still has far too much bass level.

Root Cause:

in alsamixer the bass boost is always enabled after reboot of the raspberry pi --> see screenshot


login via ssh and always change the bass boost by selecting the entry and pressing “m” button on keyboard to disable. Unfortunately the setting always get lost again.

root@volumio:/home/volumio# alsamixer


Any Ideas what I can do to prevent volumio to change the alsamixer bass boost settings. My other alsamixer setting remain untouched, only the bass boost settings change.

Any help is very much appreciated

Solution for the “Bass Boost” Problem:

After searching for hours in the Startup scripts in order to find the position where “volumio” umutes all amixer or alsamixer settings I finally found the script:


Loops through all settings:

I changed the script and added::

[code]amixer scontrols | sed -e ‘s/^Simple mixer control//’ | while read line; do
amixer sset “$line” unmute;

AZI Unmute Bass Boost

echo “AZI Bass Boost switched off in /home/volumio/unmute.sh”
amixer set “Bass Boost” mute
amixer set “Auto Gain Control” mute
echo “AZI done”