Queue empty in the middle of a song


I received my RPI4 (2GB) hifberry DAC+ yesterday that came with a ready flashed SD card with volumio.

I have run into a couple of issue and as these are probably user error i wanted to share them anyway to see if they can be avoided.

The rpi/volumio had some issues picking up a IP from the DHCP server. This could totally be due to my network setup but it was solved by ifup down eth and ifup up eth so not sure what was the cause of this.

After a few hours of use i noticed suddenly in the settings both wireless and ethernet showing as disabled and out of the blue i lost all connectivity. Again i had to go in (attaching screen and keyboard) and ifup down etc. to get networking back up.

However the most pressing issue i ran into just happened. I was listening to some music over Qobuz and suddenly the music stopped. As I had been using volumio for several hours today i had a nice queue history build that was a nice various collection of songs both on tidal and qobuz. However not only the music stopped but now the queue is empty as well. And so far it seems like there’s not way to retrieve it. Unfortunately i didn’t save it as a playlist as i didn’t expect this to happen.

Is there anything i can do (retrieve logs) to investigate this further? Not sure what caused is and i just want to make sure it doesn’t happen again or at least avoid it as much as possible.