Hi All,

I have got Volumio running wirelessly with web radio. I have acquired a QNAP NAS. It’s now networked to my PC with the designation Z:Music-Server.

The QNAP software was a bit daft in that it had two standard user names (Administrator, and administrator - or was that admin). Anyway, sorted that out (thanks Google) and have the NAS up and running. I have copied a music folder from my iTunes library for testing. The QNAP configurator wanted me to set up a “share”, so I chose the multimedia option.

Here’s where it gets tricky: and it seems that Volumio just crashes when I try to change anything.

I see Volumio in my browser and can access the pages. I’ve played around with this for a few days and at one point I could see Music-Server (but no music) in Volumio. I used Unholysmoke’s SSH lines, which seemed to help.

My files are in a folder called Music and I can click and see them in Win 7 explorer.

I made a mistake in setting up the NAS details in Volumio, but cannot seem to delete the mount or set up another one. I’m a bit stuck now, so any tips will be gratefully received. Once I have my NAS library working, I can then think about pulling I2S into my TDA1541A DAC (attenuators and reclocker probably required).



I have had the message: mount point deleted, updating db. I’ll leave it a while to see if I’m being impatient.

Otherwise, I think I’ll just download a clean version of volumio and start from the beginning. I’m using Beta 1.1, so maybe 1.2 will help… :slight_smile:

Update: I am using 1.2 beta now.

I have installed CIF Utils.

Just rebooting - NAS mount is wrong - must be a fault my end with user/pwd, but I think I’ve got the right details from the QNAP installation prog.

Volumio hangs when I try to remove the mounts. Any advice here. -please?

I had problems mounting my music share from my QNAP as well.

When I tried

NAS ip: (ip of my QNAP)
share folder: Multimedia/Audio/Music

it wouldn’t work

When I tried

NAS ip:
share folder: (blank)

It mounted.

The same trick however isn’t working on the Volumio android app. Just can’t get it to find my music share. Anyone have any tips?

Thanks - that looks promising. I can’t actually get into my Pi via Volumio at the moment. Once I do, I’ll try this.

The QNAP software says that my NAS multimedia is at 192.168.1.xxx:8080/Qmultimedia, but has no files listed. Odd, seeing as I have sight via Win 7 and my test folder is clearly visible.

Edit: I can see them now.

Going to try “Qmultimedia/Music” and see how we go.

Update as it comes!

So, I’ve reflashed and tried to get my wifi working. Stumbling block here - can’t see the network in wicd-curses. I suspect my dongle has died. I’ll get an Edimax on the way - can’t recall the make I got originally, but it seemed to work OK. I notice that the donble and USB port on my pi are more than warm.

However, every time I change any parameter in Volumio, it just hangs and I need to power down. Any reason why this might be, please? Or am I expecting it to happen far more quickly than the pi takes?

Edit: Edimax is on the way. My old dongle seems to have given up the ghost.

I can get my iTunes using the pi as an airplay device, but I really want to be able to stream from the NAS. Shame really, as once I crack this, I can move onto pulling I2S into my TDA1541A DAC with a reclocker.

Cheers for now