Qnap NAS drive mount problem

Hi there,
I recently purchase a QNAP NAS (ts-212) update with last firmware and I started to add several FLAC files inside.
I also set the NAS to shutdown at 1AM and restart at 10.30PM.
The NAS has a static IP
But, at every restart of the NAS Volumio doesn’t recognize the nas drive and I have found a workaround, bit annoying: in the source folder on Volumio I have to edit my path to the drive, click on “save” and magically the drive is recognized.
I am using a Nvidia Shield with Kodi, and there is no problem at every startup to recognize the drive
I also try to add vers=2.0 in the option field but without result

What can I do?

Some screenshoot

my system:
Volumio 2.853
Raspberry Pi 3+B
LAN connection

Cheers from Italy!

Gian

no one have had this problem before?

thanks

up the request, thanks

I also observed this on my synology nas with cifs… Not with nfs

So with nfs mode have you solved? If I remember correctly I tried NFS mode but the Nas was not recognize by Volumio

The nfs used to work but I remove it and I could not make it work again… So I have tried with cifs… But I want my nfs back :frowning:

Yes, I tried the NFS mode but the NAS is not recognized. With CIFS the NAS is recognized.
So is there an option to work with the NAS without save every time I want to access?
How do you set everything?
Many thanks

Now I have cifs and if I restart the server I need to perform exactly what you have said

So, maybe it’s a bug? Any guru tech can provide us some info about this?

Thanks

up, error continue so far…