Project with PeppyMeter Screensaver Plugin for VOLUMIO v2.9xx and 3.0xx buster

Оn all skins after setup. I didn’t install any additional.

Then install one of mine. They all display the cover.
(Click on my Avatar and download)
There must be a cover in the music folder, e.g. a folder.jpg
There must be an entry in the meters.txt file (example):
albumart.pos = 8,11
albumart.dimension = 300,300
If missing, there will be no cover

1 Like

Hi! I installed Volumio latest test version 3.342 today. Pretty happy to say that you don´t need to uninstall Peppymeter screensaver to do it. Nice new menu too…

You never had to uninstall :). It was enough to turn it off :stuck_out_tongue_winking_eye:

1 Like

peppymeter on the woody looks good now :smiley:
not wrong on the metal philips nos dac either.

1 Like

Well. that didn´t work for me on earlier system updates…

Hi All,

First of all, I really enjoy this plugin and really appreciate those who contribute. I have this problem which I first thought isn’t Peppymeter related, and I hope someone with the knowledge can help.

I just did a fresh Volumio (ver.3.324) install today with two plugins Touch Display (3.3.5) and PeppyMeter Screensaver (1.3.0) turned on. As soon as I play any flac music file (24 bit/44.1khz), I receive the “alsa” error (screenshot below) and unable to play the song. I have tried many different albums with the same sample rate and received the same error. However, I don’t have any problem playing any flac file with 24/48, 24/192, or DSD files. As soon as I turn off the Peppymeter plugin in Settings, I’m able to play 24/44.1 with no error. I have swapped two different DACs, and the exact thing happens, so I don’t think is DAC related. I really want to make this plugin work, and most of my library are 24/44.1. Any assistance is really much appreciated!! Thanks!

1 Like


I’m quite fresh in this topic with Volumio but if I had the problem now my first thoughts would be…

Where do the files come from… Hard drive, Usb etc? and maybe therefore… Sufficient power supply?

What about the memory ?.. query the system info plugin…

Which computer is it actually… Rpi 2b, 3b etc…?

What kind of DAC is it… HAT or USB?

Which plugins are still installed… e.g. the fusionDsp?

How big is the monitor or what resolution… goes back to memory?

Some more information would be needed to track down the error or to narrow it down. I personally tap on memory /clock speed… as if the computer briefly reaches its limits with this Flac.

Just a thought




thank you very much for this information… and I sheep’s head wonder about the stubborn behavior and reinstalled everything… :weary:

something new every day… :smirk:

Unfortunately, neither “black G700” nor “white G700” skin is launched. The rest are working. What could be wrong?

read-write permissions?

…everything is simple. it was necessary to unzip the zip in the same folder, and not copy to it. but doesn’t quite fit my 1280x400 display. :frowning:

1 Like

Where do you fix DNS? in the model or in the Pi. Can you guide me specifically, I have the same error as you

Thank you so much for creating the instructions and the plugin. I almost attempted the manual install before I spotted the plugin route:)
Just installed it on my rig (PI4 with the 7 inch touchscreen display). The plugin installed without a hitch. Even Spotify worked without any edits to any conf files.
Before the reboot, the screensaver used only part of the 800x480 display. The reboot fixed that.

Hi, try changing the ALSA selection as below.

Modify the userconfig.txt file. Add your monitor resolution.
But First try adding:

it didn’t help

I understand that the "disable … " entry didn’t help?
If so - add an entry with your resolution

e.g. like this:
hdmi_cvt 1280 400 60 3 0 0 0

Or see the monitor manual.

hdmi_timings=400 0 100 10 140 1280 10 20 20 2 0 0 0 60 0 43000000 3

my monitor works great. just a bigger skin.
I just started using this monitor. there are problems with setting up in kiosk mode, increasing fonts, dimming the background … I want a lot)

After enable/disable “disable_overscan=1” dont work increasing fonts.

Oh, I didn’t pay attention. After all, this skin is for a different resolution 1920x480 !!! How is it supposed to work for you?
It has to be modified
Click on my Avatar, there are 4 skins for your resolution. Check if they work

:slight_smile: Thank you. In which folder should the archive be unpacked?

Closest to your resolution … custom_6 (1280x720)
or any, but only 4 skins will work. Don’t forget to copy the text to meters.txt