Project with PeppyMeter Screensaver Plugin for VOLUMIO v2.9xx and 3.0xx buster

Solved!!! ( almost…I have only to adjust the screen)
Nothing custom folders…
all ok now with a fresh installation!

THANKS!!!

…any idea for screen adjust?

Please add to userconfig

disable_overscan=1

Hi I am also facing the same issues…not getting the full screen

Please advise if disable_overscan=1 this resolves the issue…Also am extremelyt sorry but am new to this Peppymeter world but can u please help me as to exactly where I need to make this change for disable_overscan=1

sudo nano /boot/userconfig.txt

Add to the bottom:
disable_overscan=1

CTRL+O
CTRL + X

sudo reboot

Sorry for asking this stupid question maybe…Does this needs to be done at Terminal

That’s easiest, using ssh. You can also edit files in the boot directory by inserting the SDcard in your PC.

yep, terminal it is.

after
disable_overscan=1 ( the command it’s present in my folder )

PeppyMeter it’s more cut in my display…

I try all custom resolution …but image it’s always huge…

Hi, which is your native display resolution?

From china…with love…

1 Like

Hm, it seems it supports 1280x800, but it’s not shure if this the native resolution of this panel.
Perhaps you can detect the used panel inside the cover.

Same problem here, tried to manually start, this is the result:

volumio@volumio:/data/plugins/miscellanea/peppy_screensaver/peppymeter$ DISPLAY=:0
volumio@volumio:/data/plugins/miscellanea/peppy_screensaver/peppymeter$ python3 volumio_peppymeter.py
pygame 1.9.4.post1
Hello from the pygame community. Contribute - pygame wiki
Traceback (most recent call last):
File “volumio_peppymeter.py”, line 113, in
pm.init_display()
File “/data/plugins/miscellanea/peppy_screensaver/peppymeter/peppymeter.py”, line 150, in init_display
pygame.display.init()
pygame.error: Unable to open a console terminal

If I sudo the second command as in

sudo python3 volumio_peppymeter.py

then something happens, that is the screen goes blank and I got no error, screen returns to playback when I press control-C to exit.

Another fresh installation …and now…it works!!!

with custom6 (1280x800)…thats perfect!!!

Thanks for the kind help!!!

I‘m glad to here this.
:+1:

@massimogentilini

sorry that’s my mistake the command for test before you run the python command is

export DISPLAY=:0

You will be an expert once you finish the 5th installation… :slight_smile:

Andy

Got it working…

Steps:

  • Clean Volumio3 installation
  • Installed Touch Display Plugin
  • Installed Balbuze plugin
  • Installed your plugin
  • Updated kiosk startup script with parameters for Chromium (begin of this thread)
  • Disabled Balbuze Plugin
  • Reboot

Still not clear if Balbuze install is helpful or not (I do not think so but I do not want to restart again on a fresh installation, if it works… don’t touch it!).

IT WORKS NOW!

Yes….Thanks your help!
And now….
It look very nice….
It’s possibile to install peppymeter also on Rpi3+ and official 7” display ( gpio…)
Thanks again!

1 Like

Yes it’s possible. The official 7“ display have a resolution of 800x480. I have generated some screens also for this resolution.
A pi3 have only 1gb memory. To use the PeppyMeter in random mode it’s important to deactivate the cache mode. It’s not enough memory free to use the cache mode.

Hi 2aCD,

Is there a way to enable/disable the screensaver via a GPIO pin. So having a pushbutton to toggle through different displays. (playnow/peppy)
Using a piece of code that overwrites the timeout with a high or low number will not work without a save or volumio vrestart.
Any ideas?