Project with PeppyMeter Screensaver Plugin for VOLUMIO v2.9xx and 3.0xx buster

It doesn’t work for me. The level meters are stationary. I’ve tried all the ways. Nothing helps. My friend has exactly the same.

Hi @Marek_Grzeszczak,
when the meters showing without moving, it seems, you have an alsa problem. Do you use Volumio 3.x?
Have you try both alsa options in the plugin settings, also the variant for DSD native and please use at first an internal source (usb or internal). If this is working?

Yes, Volumio 3.x I also tried. Not working.

Hi, I do not get sound when I play radio paradise with mixer type hardware, have to put mixer to software to hear something. Is there anyone who can help solve this?

1 Like

Did you do a fresh install? If not might be worth giving that a try…

I see meters still not moving with 3.173 when using tidal connect…or am I missing something?

Thanks

Does Peppymeter work with an external screen on x86 VolumIO?

1 Like

If you manage to run the meters, let me know.

1 Like

The meters work for me no problem at all, the only time it does not is when using tidal connect but believe this is a known problem and didn’t work in version 2 either.

Now I know why they don’t work. I only listen to music through Tidal Connect. Tomorrow I will try and let me know if it works with FLAC files. On the first version, volumio 3.163 worked through Tidal Connect. Peppy Meter - YouTube

Hi, yes with latest Buster version 3.173 the meters not moving with tidal connect. I have not found the reason for this at time, but I think the alsa pipeline is not used with tidal connect, but I‘m not shure.

Please use the local Tidal as workaround then the meters are moving.
Best regards
2aCD

1 Like

It works. Is it possible to increase the signal to the level meter? They lean very slightly. Udostępnij - YouTube

On my Pi4 at 3.173, the meters move without any connection to the music, as if following a pattern. Not working in Spotify despite fixes in files.

Hi @2aCD

Running Peppy on a rPi4, Volumio 3.179. It occurs that when I play a single track (or last track of album), PeppyMeter will stay active when the songs end. Causing the touch_screen screen saver not to become active.
IMG_3703

Hi @Wheaten,
yes this is a known little issue. The play stop event is missing and the peppy screen is still showing.
If you press play and stop on smartphone again, then the peppy screen exit correctly.
But I think, a touch event stops the screen also.
I’ll look if a event is triggered, when the Musik play end’s without user interaction.

yes, its a bit confusing. You catch the status update, it receives a stop event however peppy (or timeout is not responding to this). I abused peppy to send disp_off for the OLED above the touch screen, which is working.

HI,
I try to install this awesome plugin ( great help from YouTube guide by Andy young)
my setup
raspberry 3b+
allo boss dac hat
1280x800 10.1 hdmi display
Volumio 3.179
touch screen plugin 3.3.1
PeppyMeter plugin 1.3.0

installing PeppyMeter plugin …with no error …
setting touch screen plugin ( 60 sec , 128 memory and flagged on “no screen saver while playing”

PeppyMeter set to 30 sec …alsa modular

plugin not start…only Volumio interface on screen …or black screensaver if no Playing

any help will be …a great help!!

thanks!!

I’m sorry for my bad English

Hi, please try that at first:

  • open putty and login
  • change to follow directory:
cd /data/plugins/miscellanea/peppy_screensaver/peppymeter
  • and start the peppy screen manually:
export DISPLAY=:0
python3 volumio_peppymeter.py

If this start the peppy screen?
And be shure you have set the correct screen resolution:

image

1 Like

Hi,
THANKS!!!
i will try soon…but I don’t have this choice…( custom 4 1920x1080)


but only small-medium-large …

Ok, you don’t have the custom resolutions?

image

please look in your folder:

image

Do you see the custom folders?