Project with PeppyMeter Screensaver Plugin for VOLUMIO v2.9xx and 3.0xx buster

May i please very polite ask if soomeone would be able to create this awesome VU design, i think just background would be OK

I am not so good in graphics
thanks
Ed

1 Like

do you mean the complete front or only the black VU-meter. And for witch resolution do you need it.
Perhaps when I have a little bit time, I can’t try it.

1 Like

Only the black VU, res. 800x480, many thanks

1 Like

@EddieCz
I see that’s this meter type is already available. It’s the white red meter. Is it ok so for you, or need you a modification with additional text?

@2aCD Yes, but i would like to ask for mono version without metal elements and knobs, just pure VU, many thanks

Have you look in the ‘large’ folder (800x480)? Please select it as screen.resolution in the config.txt instead the custom folder. Then you have pure VU-Meters without external backgrounds. As meter set then black-red. I think this is what you want.

Where did you get the stand from?

1 Like

@2aCD I found there white red, which is similar, many thanks for that info

I’ve stumbled across this recently and have followed this verbatim, however, seems there are some dependancies that exist that I cannot get around.

I have a clean install, with the relevant changes to get this display working and that’s all good. However, it falls apart with peppyalsa.

volumio@volumio:~/peppyalsa$ sudo apt-get install build-essential autoconf automake libtool libasound2-dev libfftw3-dev

...brevity...

libasound2-dev is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 build-essential : Depends: gcc (>= 4:4.9.1) but it is not going to be installed
                   Depends: g++ (>= 4:4.9.1) but it is not going to be installed
                   Depends: dpkg-dev (>= 1.17.11) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

And it goes downhill from here as attempting to manually install dependancies cascades to more and more dependancies and has broken everything. So I will start again with a fresh install and get back to this point. I’m open to suggestions.

You might be better off downgrading – this is a recent known issue with current Volumio versions.
See Cannot install build-essential package for more details.

1 Like

Ahh…a recent known issue. Thanks for that and I’ll keep an eye on that thread.

Thanks!

1 Like

hi 2aCD,
I was very excited about your work, I just got a Waveshare 7.9 "touch screen, 400 × 1280 - I already know that it’s not the same as 1280 x 400 :slight_smile:
I would like to use a simple layout for my system - similar to lausiv + VU meters. (I loved the squeezebox touch in this - sometimes I hug my head why I let it go). Since I’m not very linux friendly, you could pave me what and how.

@CDRG
You find now also a workaround here:
cannot install build essential package

1 Like

I have update the step by step guide and add installation scripts for all steps to an easy installation, after a system update.

The implementation works now with VOLUMIO Jessie and Buster.

Have fun and best regards
2aCD

4 Likes

Hello,
I want to buy an display only for this project to use as main streamer. What model is your
display.
Or better should I go with a display and a external controller, but I guess this is not with touch
Thanks.

Hi, this is an 5,5” AMOLED with 1080x1920 from Waveshare. It comes with some adapters for a direct connection of hdmi and usb and touch with a Raspberry.

1 Like

Thanks for your answer,
The display looks indeed very very nice.
I guess the config will work also with a normal 10 inch 1920 hdmi display?
The peppymeter uses the new alsa pipeline for volumio 3.xx, if yes then it will work also with spotify and qobuz ?
Regards

Yes this config works also with a 10” 1920 hdmi display. Only the hdmi timings in
/boot/userconfig.txt, and rotations are different. I have all this settings in the separate amoled script, you don’t need it. Also the scale factor, what you need is a little bit smaller for 10”, I think 1.2 or 1.5 in volumiokiosk.sh.
Yes with Buster the new alsa pipeline is used. With Spotify you have no albumart preview for PeppyMeter. But I have the background pictures also without albumart and title info panels.
But I have no test it with Spotify at time.

2 Likes

Thanks for detailed explanation.
I am also using qobuz, this will have Album art in peppymeter?
I have to convince my wife why the he’ll I need another display :)))

You need a high WAF (woman acceptance factor) :grin: For the albumart picture I use the albumart cache /data/albumart/… I think the online services don’t use this location.