Project with PeppyMeter Screensaver Plugin for VOLUMIO v2.9xx and 3.0xx buster

First of all. Thanks for your hard work. This plugin is amazing. I enjoy a lot. I wonder if it´s possible this skin in 800x480
Regards
6a15968e06f5e1f62dafcc1f28ca4d9e1f583159_2_666x500

Hi femagon,
yes please select the custom_800. and set the screen resolution to 800x480 in the plugin.
Best regards
2aCD

WOW!! It works. Thank you very much.

1 Like

2aCD

Thank you much for PeppyMeter… incredible work.

Not just visual, but VU Meter also very responsive.

Why PeppyMeter not yet as regular Plugin (note to Volumio devs).

My experience:

  1. Upon 1st try installation of PeppyMeter, something got corrupted as per final restart, Volumio turned unresponsible and could unreachable from browser.

  2. After new Volumio flash install, PeppyMeter installed - as expected

  3. All mostly works, besides a minor scale issue - which cuts portion of the PeppyMeter; tried many ways, but scale/resolution is mostly not responsive to change (1920/1080)

Xant

Hi Xant,
thanks for your reply.
PeppyMeter is wrote in python pygame. This is needed to show smooth moves of needles with a high refresh rate.
Pygame write the screen buffer direct. Therefore absolute width and height values of screen buffer size needed. This values not scalable, that means, have you another screen resolution as the available meters, you can’t scale to your resolution. In the next version I have removed the separate resolution values and grab the values from the selected folder.
Then there is no more confusion. You select the right folder and that’s all.

At time the following screen resolutions are supported:
1280x400, 800x480, 480x320 and 320x240
and with additional background:
800x480, 1024x600, 1280x800, 1920x1080

Do you want another resolution, give me a hint, perhaps I can implement this.
Best regards
2aCD

Hi together,
I have update the plugin to version 1.1.0

the changes are:

  • add a new alsa configuration for buster. Two configuration now selectable:
    1. with an integration in the alsa pipeline (then DSD-files reformated to 192khz but all sources running with peppymeter
    1. separate mpd output for peppymeter (DSD-files native working, if you have a DSD-native compatible DAC, but online connect services [spotify connect, tidal connect] have no moving neddles)
  • no more separate screen resolution values are needed, the resolution is defined with the selected folder
  • some little UI-changes

!! Important !! Do you want update from a previous version of this plugin, please deinstall the old plugin at first and install the new downloaded plugin again

have fun
2aCD

2aCD

First of all, thank you for prompt reply.

I acknowledge your note regarding a “steady” background and high refresh rate for needles. Indeed!

That said, the “custom” resolution is misleading, as I tried many variants at no solution or change, but now clarified per your note.

Its “weird” that my “not so new” TV cutoff PeppyMeter at 1920 (which it was supposed to “be”, but cut).

So, now that you clarified… I do understand that might be on my “TV end”, and trying to adjust (TV settings seems dated, and still trying to figured out). That is, 1280x800 shows small, while 1920x1080 gets cut-out (any in the middle?).

I indeed appreciate your kind offering to adjust to “other non-standard” resolution (whatever it might be), but think it’s “futile”… ie, too much work for a resolution that it is NOT standard (and still trying to find-out).

Changing subject, the recent “bug” or whatever be, is that on Spotify (connected by plug-in), the needles doesn’t move (ie, not sure if Spotify plug-in problem, or Peppy). During Spotify, Peepy correctly shows all info (bit rate, etc), but no needle movement.

Xant

Hi @Xant,
For Volumio 2.x, all services which not use MPD as player needs to redirect the output device to peppyalsa. For Spotify Connect I have explained here:

https://community.volumio.org/t/volumio-project-with-1920-display-and-peppymeter-as-screensaver-for-volumio-v2-8xx-and-3-0xx-buster/45862/240

and for Spotify here:

https://community.volumio.org/t/volumio-project-with-1920-display-and-peppymeter-as-screensaver-for-volumio-v2-8xx-and-3-0xx-buster/45862/10

I think you have a full HD TV, the it‘s important to set it to input for PC without scale and use 1920x1080.

For a long time some TVs had a resolution of 1366x768 (half HD) but that was rare.

You can try with a laptop to find out what’s the right resolution but look at first to disable all scale on hdmi on the TV
best regards
2aCD

Hey @2aCD

Thank you once again.

  1. Spotify
    That was eaaasy. Apologies as I confess not searching first…

  2. TV Resolution
    Still trying diff a no result. Did connected a laptop in PC port, and did got 1920x1080.
    But now understand that issue on my side (not PeppyMeter).
    If no solution, it cuts some, but I can “live with it…”.

  3. What is “appearance.zip”?
    I changed Volumio color highlight before, but then can not update regularly (as file modified), or have to change CSS color code everytime… (and no longer wishing this path).

Extra note:
At time, a red color started flicking on top-right corner of the screen. Upon get closer, noted be a “thermometer” icon. Hmmm… sure, figured out might be RPi4 getting hot.
My RPi4 has a small passive aluminum cooler on top of chip and no room for fan, as there is an Allo hat on top.
Try to improve vent, and “thermometer” no longer showing. But if so, will try to squeeze cooling fan hat in between…

Xant

Hi Xant,
with the appearance.zip you have many additional settings to change the appearance of standard views. Yes, if you have install this addition, you can’t update volumio, therefore I have also an uninstall script created. With this you can uninstall the addition and after Volumio update install it again.
Please look here at first:
https://community.volumio.org/t/contemporary-optimizations-for-small-or-large-landscape-displays/44270

To check the cpu temperature you can use

vcgencmd measure_temp

My PI4 with 1920x1080 display and PeppyMeter go to 65 grad Celsius, but it is vertical and without case with a small passive cooling.
Please look which temperature your cpu reaches.
Is it between 70 and 80 grad Celsius, then I think you need a bigger cooler.

1 Like

Hey @2aCD

All comments acknowledged. Thx.

Tracking temp, which now around ~60.C with PeppyMeter running. I removed some side casing, which might have improved passive cooling (and checking/tracking).

Hint to others:
% sudo watch /opt/vc/bin/vcgencmd measure_temp

Xant

In addition I’ll test this version of heatsink for a PI4,
it should fit under a DAC

Hi,
Very interesting this heatsink.

yes, I have order it as 3mm and 4mm version to look how it fit under a DAC
:wink:

Could post a link

https://m.aliexpress.com/item/1005001691525070.html

But without warranty :wink:

2aCD et al

Apologies to divert this forum to a different discussion… but it seems Temp now relevant.

After taking some casing out (which my RPi4 “looks weird” lab experiment), temp still holding ~60.C after whole afternoon on PeppyMeter.

As mentioned before (even at Volumio discussion), I can not allow myself credentials to “Audiophile”, but if Passive Cooling is possible… always better than more electricals (ie, fans) interference.

Nevertheless, I advice ALL to track Temp… if FAN needed, so be it (many options on Amazon or so).

Xant

1 Like

software version 2.909
dac khadas tone 1.

I don’t get it anymore, I’m changing the line

[output]
device = '${outdevice}'
with

[output]
device = 'peppyalsa'

in /data/plugins/music_service/volspotconnect2/volspotify.tmpl and then the vu meters don’t move.

If I do the exact same in buster beta then it works, the meters move nicely.

what am I doing wrong?

If you need more information, I’ll be happy to provide it.

Thanks a lot for awesome plugin @2aCD. However I am facing a small issue with the display. Just installed today.

Current setup is RPI4 connected directly to Samsung LCD.

Volumio version 2.907.

Issue: I am getting the overscan of meters overlay. I have tried various combinations using both touchdisplay + peppy meter for the resolution and resizing to fit within the TV display. But it is not fitting to exact size. Here is the image for the reference

Hi @Sanjay74
at first it’s important to disable all scaling on the tv. On some tv’s this is standard on hdmi. You can check this with a PC on this tv.
The second thing is, the raspberry have a scale of ca. 0.9 on hdmi port (overscan) Please disable this also in /boot/userconfig.txt

disable_overscan=1

And then use the 1920x1080 on PeppyMeter settings.
Then it should be work
Best regards
2aCD

1 Like