Problems with Weiliang XMOS dual AK4399 DAC

Hello, i’m experiencing serious problems using Udoo Quad + Volumio with my dual AK4399 + XMOS chinese DAC from Minishow seller (Weiliang project): … 1e87392ea8
The DAC itself is very outstandingly sounding for the price and it plays flawlessly attached to my PC with Foobar 2000, even playing DSD files. It needs Weiliang proprietary XMOS drivers in Windows though, as using reference XMOS drivers it won’t work.
When attached to Udoo + Volumio beta1, 2 main issues occur:

  1. When i boot Volumio using a freshly-written micro-sd the DAC plays well (using an USB pendrive as media storage), without the need to change any setting; but as soon as i reboot Udoo (even if some days pass between shutdown and restart), the DAC won’t play at all: playback in Volumio starts normally and time counter goes on, but no sound is output by the DAC. At this point, the DAC won’t output whatever change i try to Volumio settings, just until i pull mini-sd out of Udoo and write it again using Win32DiskImager. Then it will work once again until i reboot…
    That’s really strange, i guess what could have changed in Volumio micro-sd after the first boot, considering i don’t change any setting at all…
    But you can guess that this way the Udoo + Volumio + DAC combination is practically useless.
    N.B. If i attach the DAC to my PC, it plays well at any time.
  2. Even during the first session after micro-sd is written, the DAC refuses to play DSD files if attached to Udoo + Volumio: like above, Volumio playback starts and counter goes ahead, but no sound is output. The same DSD files play well on my PC using Foobar2000.
    I suppose there is a driver problem, as DAC XMOS needs proprietary drivers and reference XMOS drivers are not working well with it. But i only have Windows drivers and i don’t know if Linux drivers are available for it…
    Would it be possible for you to obtain appropriate drivers for it to add to Volumio drivers database in a future release?

i also use xmos usb interface but i haven’t problem with volumio.
i work with beagleboneblack and in hardware section you will be see X20.
In this case the usb interface hooks the dac and you can listen a sound.

Yes, but i think that this XMOS interface is a bit different: in effects, it needs proprietary drivers and doesn’t work with reference XMOS drivers.
Anyway, even if i select X20 the DAC doesn’t play if i shut down Volumio using its software power off function. Instead, it will play after a reboot if i shut down my Udoo by pulling away the power cable without using Volumio’s software power off function.
Anyway, playing DSD files the DAC refuses to output sound whatever i try - but in Foobar 2000 they play without problems.

I have the same problem with the XMOS PCM5102 (32 bit, 384K). Works fine for 1 time when freshly written SD card then no sound. I think the thing is volume data is sent to DAC as well as bit stream (or how does hardware volume work). Dac shows correct speed and connection, Volumio shows correct play time etc but no sound. Rewrite the card and all is well again (for one time). The only windows drivers supplied with DAC only go up to 24 bit, but Udoo quad + Volumio plays 32 bit OK. No idea of the solution.

You have to shutdown udoo unplugging the socket and it work. If you shutdown or reboot udoo with software it did’nt work anymore. This is a work around, the bug is not resolved at moment, perhaps in the next version.
You can also save x20 conf in the web ui, but don’t reboot or shutdown via software and the dac work.

Inviato dal mio SM-N9005 utilizzando Tapatalk

Guys, try to type alsamixer and veryfi if the device is muted.

From my experience with this DAC, the problem is with asound.state file.

For some weird reason after first reboot, it’s like it’s muted although it is not.

What I did in archLinux is what is described here: … d.state.29

I do not know if you can follow the exact same procedure in debian but the steps should be similar.

Sent from my GT-N7100 using Tapatalk

Or lock the alsa state at the first boot… So it will not be muted again. However, in next version I’ve implemented an auto-unmuting script which will prevent this behaviour to happen. Quite some people are reporting that, some with hiface-2 some with XMOS receivers (not a problem with mine though…).

Finally solved my version of the problem with Udoo quad. I bypassed the power input under the Udoo board at the plug pack input with 100uF 25V cap and all is well. There is a surface mount cap there but it may not be enough to stop spikes on power down.

Very good! Could you post a picture of your mod?

I downloaded and installed newer version (V1.4) Volumio but the issue is still there…

Sid you try to log in and run alsamixer? (even though the have included an unmute script in 1.4) Also you might take a look here: … -mute-mode

The problem also depends on how the xmos firmware is configured. If the master volume control should be disabled or not. (quick test: connect to an OSX system, if you can’t control the master volume then it’s disabled). The bug probably affects xmos cards that have the master volume ENABLED.

Note that even if the master volume is disabled in firmware, you can still turn the master volume up/down with alsamixer, even when the music is playing and mpd is configured to use a hw output.

Yes, i tried launching Alsamixer after logging in using an ssh client, but screen flashes and nothing happens: Alsamixer doesn’t even open…
Hardware volume control does nothing in my running Volumio 1.4: it doesn’t affect DAC volume.

Strange. Maybe you could try with another ssh client? I’m pretty sure it’s a “mute” problem.

I’ll try. But what about unmute script in Volumio 1.4? Why it doesn’t work then?

UPDATE: i finally got to launch Alsamixer in SSH using an Android device. You were right: X20 device was muted and unmuting it was enough to get sound back after reboot!
What i still don’t understand now is why Volumio 1.4 unmute script doesn’t work… maybe i should do something to launch it? Isn’t it self executing?