Problems with the last Volumio (2.699) on a Raspberry PI

I am experimenting problems with the last Volumio (2.699) on a Raspberry PI3 and an USB DAC (Fiio K3).
The system is very often not accessible (red light on Raspberry).
I have replaced the SD Card (Samsung 16GB) with a brand new (Sandisk 16 GB): no results.
I have replaced the power supply (original Raspberry, 2.4 A) with a brand new (3 A): no results.
I have tried to install Moode Audio in the same configuration and it works perfectly.
If I disconnect the USB DAC, it seems to be better. It works.
Could it be a problem related to the power drained by the USB DAC?
What changed with this version?
Why no problems are experimented with Moode Audio?
I really prefer Volumio over Moode and I hope to find a solution.
Any suggestion?

Sorry to say but last upgrades are not working as they should.
Revert back to older Volumio software and your problems should be gone, mine did.
I’m on 2.668 from 14th of november last year and Volumio is running troublefree

I read in another post that they have observed SD corruption when the power supply has capacitors and it disconnected. The “slower” decrease in tension below 5V may cause SD corruption.

I will try to remake a SD with the 2.699 image and interrupt power supply by shutting down and then abruptly removeing the mini-usb from the Raspberry, without unplugging the power supply (I should have bought a model with a switch on the cable…) and see if this is works.

Otherwise, I will try to revert to the older version.


Yes please let us know.

Dear Michelangelo

Problem confirmed with 2.699

2.699: no problem with setup, rebooted and …lost . Tried to write the image 3 times without succcess
2.698: no problem with setup, rebooted and…everything perfect. I tried 3 reboots and it is immediately accessible.

So, I really think we have some problem with 2.699


And to reboot I always performed a full shutdown, then removed the cable from Raspberry (with the power supply still connected).

Please put your device in test mode and update to latest beta release. this should solve the issue.
please let me know

Dear Michelangelo

It worked!
Updated to the last beta and, in my preliminar tests, eveything is working.
Just for curiosity, have you figured out what was the problem with 2.699?

Thank you for your help


Yes, restarting MPD on every startup exposed a bug in MPD. This bug originated from MPD hanging if a NAS was mounted and inotify ran out of watchers.