Problems with organising in Volumio

Hello there,

I’ve been trying for some time to get my library organised on Volumio, but still have these problems:

  1. I have some Nick Cave & The Bad Seeds music and I put all the albums in a folder titles “Nick Cave & The Bad Seeds”, I also tagged all the albums as “Nick Cave & The Bad Seeds” for both the artist and album artist. Now the problem is that in volumio by artists, I have “Nick Cave & The Bad Seeds” and “Nick Cave and The Bad seeds”. What can I do to have all my Cave albums under "Nick Cave & The Bad Seeds.
    Knipsel.PNG
  2. Some albums show cover images that are not in the tags of that album anymore. I retagged all my music so that they all had 1 cover image, that same image I also put in the album folder with the name “folder.jpg”. So Volumio shows an image as album image that is not in the tags of the album, nor in the folder of that album. How can I fix this (resetting the album art cache does not work). Knipsel3.PNG (Here you can see that I get an image of the back of the cd, this image was in the tags, but I deleted it and now it only has the cover image, but it still show the back)
  3. Some albums just don’t show any album cover, for example 'Our Endless Numbered Days" by Iron and Wine, even though it has the album covered in the tags and as an image in the folder. Knipsel2.PNG
  4. If I check the songs of an album, 9 out of 10 all the songs are there 2 times. (I can’t add another image)
  5. This is not really a problem, but more of a question. Is there a way to choose an image for the artist?

Maybe this can help with finding what I’m doing wrong, this is my filestructure:
Music folder > artistname > year-albumname > songs(flac)+folder.jpg

Thanks in advance for any help.

Q1. Double check the artist and album artis tags for Mr Cave. I had the same issue with Echo & The Bunnymen, there were three variants of the band name in tags between about six albums. After you’ve found and corrected the anomalies, do an Update Folder on the root of your music store.

Q2. I had a ridiculous issue with one album under one band, it always showed a broken/missing image placeholder after I added a corrupt folder.jpg with the audio files. I replaced it many times with a good version, but could not get it to display correctly. Eventually I reset the image cache and that did fix it. In your situation, I’d probably delete that album and its files from the Volumio music store, update the root of your music store, [perhaps even restart Volumio). Then re-upload the album with known good files and artwork.

Q3. I think your cover art (folder.jpg) might be too large on the albums where it doesn’t show correctly. On music I buy from Bandcamp, it will often have large 3000px or more cover art included with the audio files.
I’ve learnt to resize that down to 500px (it seems like a good compromise size to me) and upload that resized image as folder.jpg. I also add the original large cover image as folder-lg.jpg as it may be useful in the future.

Q4. I wonder if you have a .cue or .pls file in there with the audio files? I don’t think Volumio uses playlist or cue files though, so I’m not sure if that could cause the double appearance of songs. I don’t suppose you’ve accidentally uploaded both .mp3 and .flac versions or similar? I’ve not seen double listing of songs on my Volumio.

Q5. It seems that those band photos are sourced from the web, but exactly where from and how hasn’t been explained. I have a few lesser known Aussie bands that don’t get a band photo in Volumio.

Thanks for the quick response.
Q1: I checked it and they all have the ‘&’ character in their tags.
Q2: I’ll try this
Q3: This was the case and I shrunk the image.
Q4: I don’t have the cue files anymore and there also aren’t any mp" files, only the flacs. Even checked for hidden files and that isn’t the case too. It’s trange because I don’t have this problem with some albums, but with most it is a problem.
Q5: Yes, they are also mostly small unknown bands, but also Nick Cave & The Bad Seed (in both spelling variations) so that seemed strange.

So I think I found what the problem was with the old cover images and the duplicate songs.
Knipsel.PNG
So when I go to Music Library In volumio and to my harddrive, I have my music folder and also this folder. On further inspection this contains the older versions of albums (older tags and covers). So I want to delete it to get rid of my issues, but when connecting the hardrive to Windows, I can’t find the folder. I also did “Show Hidden files”. Does anybody know how I can delete it?

I reformatted my drive and the folder is gone.

$Recycle.bin is the Windows trashcan folder. It is hidden by the Windows system but directly accessible under Linux.

Good work, it sounds like you’ve fixed most of the issues. I wonder if the rogue Nick Cave And The Bad Seeds was also coming from that sneaky recycle bin?

I put my music on the USB drive connected to Volumio over the network, it appears as an SMB share \volumio\USB
That way I avoid connecting the drive to my Windows PC and getting system files and folders (like the $Recycle.bin) added to it.
You can correct tag anomalies the same way, just open the share in an explorer window (type \volumio\ in the address bar), then drag and drop files to your tag editor window, (I’m using MP3Tag), it’ll save right back to the share.

Yeah, I would do that if I had a NAS, but unfortunatly a student budget doesn’t allow me to build one. So I use and old harddrive that I directly connect to my raspberry pi. Works for the most part, but woulb be much easier if I didn’t have to disconnect my drive every time I want to add music to my library.

That’s exactly what I was trying to tell you, you don’t have to keep connecting the USB drive to your windows PC.
Open an explorer (the file explorer, not the web browser), type the name of your volumio into the address bar with two backslashes preceding it
\volumio

That will show you the SMB shares on the Volumio, go to USB, you’ll see your music library.
You can copy to and from that location by drag and drop, you can also drag the files to your tag editor for editing, etc.

I tried what you said and got this in windows:
Knipsel.PNG
But if I click it, it just opens the webui for Volumio. Any idea where I can find the USB library? I’m new to this btw.

Somehow I think you’ve either misunderstood, or your PC is acting up.

Open My Computer (or any other File Exlorer window) and select the location in the address bar, replace it with \volumio (or whatever your Volumio is called)
volumio-address.jpg

You should see the default SMB shares listed
volumio-shares.jpg

Double-click the USB share
volumio-usb.jpg

You’ll either see the Artist folders now, or the directory they are under, mine is called MUSIC
Double-click the next level if you need to and there are all your Artist folders.

See the next message for the rest, we are only allowed three image attachments per post apparently.

Continued from last message

You’ll either see the Artist folders now, or the directory they are under, mine is called MUSIC
Double-click the next level if you need to and ther are all your Artist folders.
volumio-artists.jpg

It’s possible to map the USB share as a network drive, right-click, Map Network Drive, choose a meaningful drive letter (maybe V: for Volumio)
and now you can easily save, browse, open, etc the files on your V: drive.

Ah many thanks for this clear explanation. I found the folder, but it seems that I don’t have permission to add or delete anything in this folder. Is there anyway to get this permission?

Restart the Volumio, it acts up sometimes, those shares should be public (no username/passowrd required).

Quick question: I see the shutdown button, but how do you restart volumio when it’s shutdown? Can’t find anything about it in the github docs

That’s another weird thing with Volumio.
Most of the time, I just pull the USB power connecter out, count to 10, then plug it back in.
The lights never go off if you use the Shutdown option in the System menu.
I’ve also found that the Restart, doesn’t clear up bad behaviour like pulling the power for a cold restart does.

Restarting didn’t work, I still get this error: Knipsel.PNG
It says that I need permission by Unix User\root to change anything.

I thought you deleted that stupid $Recycle.bin folder.
I’m not sure why you are having the current issue, it’d be good if the software authors ever stepped in and helped with all these niggles that seem to crop up.

Maybe you shoud try MoOde, it does seem more stable and reliable, but I strongly disliked the interface.

I thought the same, but it seems to be back, would indeed be helpfull if one of the devs could help with these functionality problems

I"ll think I"ll start a new thread for this issue. Thanks for all your help already.