Problems adding network disk

I have installed a Synology NAS on the network. When I try to add a network drive, the software does not detect my NAS. Can someone help me? Thank you

Add it manually … click on ‘add new drive’ from ‘sources’, and then fill in IP address, shared folder name etc.

Thanks for the reply. I tried to do as you say, but the software gives me a message saying that the network drive is not accessible

Firstly, is your music folder shared on the NAS? Are you going to use cifs or nfs (have a read Mounting an NFS Share - Volumio Documentation if you are going to use nfs? Do you have screenshots of the settings that you have chosen in the Volumio UI?

Basically give us as much information as possible as to what you have tried, and how.

Yes, my music folder is shared on the NAS. I used nfs (I read and followed the instructions “Mounting an NFS Share - Volumio Documentation”). I am attaching the settings I have chosen in the Volumio user interface:
Alias: Synology 1
Indirizzo IP:
Percorso: /volume1/Album
Tipo di Share: nfs

Would you share some system logs please?

Reboot your device, try to add the drive, get the log, and then post the link to the log here.

If you can ssh into your device (How to enable and use ssh.), then could you post the result of typing:

sudo showmount -e

I did have a problem with my Synology. I have a QNAP now so cannot check but I had to set the version in the options field try vers=2 I think this is the link I used when it happened to me the first time:

If vers=2 does not work try vers=1

The ‘vers’ option refers to cifs shares, not nfs.

I only used cifs for synology and qnap so I assumed Profile - tizpan - Volumio was was well. On re-reading I realized my error. Apologies