Problème lecture volumio via qobuz?

Volumio Information

Volumio Version:2.657
Hardware:
DAC:HiFiBerry DAC Plus
Bonjour en cous de lecture le morceau se coupe et saute à la piste suivante. Quelqu’un aurait il une solution?
Merci de votre aide. Yves

This is exactly the behavior I get since about a couple of weeks. Local tracks and web radios play flawlessly. No problem whatsoever when using Qobuz app on my smartphone and iPad, and even streaming Qobuz to Volumio on Shairport Sync. It follows typical mpd log with CURL errors:

volumio@volumio:~$ tail -f /var/log/mpd.log
Sep 09 20:09 : zeroconf: No global port, disabling zeroconf
Sep 13 15:01 : client: [0] opened from local
Sep 13 15:01 : exception: No such directory
Sep 13 15:01 : client: [1] opened from 127.0.0.1:45470
Sep 13 18:06 : exception: No such playlist
Sep 13 18:07 : exception: CURL failed: Recv failure: Connection reset by peer
Sep 13 18:08 : player: played “http://streaming-std.qobuz.com:80/file?uid=1054864&eid=75154012&fmt=6&profile=raw&app_id=539451548&cid=767463&etsp=1600016771&hmac=J1EvbAT9ekJDKuD4KAstI6D57Zw
Sep 13 18:17 : exception: No such playlist
Sep 13 18:18 : player: Decoder is too slow; playing silence to avoid xrun
Sep 13 18:18 : exception: CURL failed: Recv failure: Connection reset by peer
Sep 13 18:18 : player: played “http://streaming-std.qobuz.com:80/file?uid=1054864&eid=79360793&fmt=6&profile=raw&app_id=539451548&cid=767463&etsp=1600017457&hmac=ES-dY4L7UkzdM8m9pItQlLtQIIg

More than one month and some new releases have passed (I’m a beta tester of new Qobuz implementation), but the issue is still present (and seriously damaging my listening pleasure!!!).
Are me and the OP the only ones to experience this appalling behavior?

It’s only mitigated by setting a larger input buffer, but for tracks longer than about five minutes, which is quite common for classical, it happens nearly every time!

It seems to me a communication problem between mpd and Qobuz (curl error “Connection reset by peer”) after the first chunk of data has been consumed and another one is requested.
Any opinion from the developers? Could it at least be possible to ask Qobuz to stream the whole track in a singe chunk and store it locally, setting a very large buffer, maybe directly manipulating mpd.conf file as web interface only allows 12MB max?

Can you provide an album which shows this behaviour?

Sure: every track that lasts longer than about 5 mins gets truncated when the buffer is set to 12MB. With smaller buffers, the truncation happens earlier.

Want just an example? Beethoven’s symphonies box by Simon Rattle: http://open.qobuz.com/album/cfas6uw9wj2aa
Yesterday evening I tried to listen to 2nd symphony (from track 5 on) and not a single movement lasted till its end!

Hope this helps for the moment, I can give you more examples and logs when I’m back home.

Not sure this is related, but Qobuz seems to be very strict about streaming only to one device. Having the App open on your phone can cause strange problems (mostly music just stopping) on other devices…

Follow up: yesterday I set the buffer size to 1 MB (minimum allowed by Volumio interface) and tried to listen to this album: http://open.qobuz.com/album/3760061190726 which is made by many small tracks I know would have played nearly without problems with a larger buffer.
The result is that practically every track was stopped before its end.
The mpd.log file attached (renamed as mpd.log.txt to circumvent Discourse limitations) shows:

As you can see, with 1MB buffer the player in the end lost completely any connection and sync with Qobuz and keeps on playing silence long after the album end: I had to manually stop it long after saving that log file!

mpd.log.txt (76.9 KB)

Not a word from developers after 20 days…
My yearly virtuoso account expires by november 25th and of course I’m going to cancel my subscription if I still cannot properly use what I payed for.

By the way: after a little time on Google I found that the issue is well known and documented and is caused by a misbehavior of MPD in addressing multiple requests to Qobuz and Tidal servers for tracks longer than its local buffer. The issue has been verified and tentatively solved by MPD and umpmdpcli developers introducing a configuration option which makes umpmdpcli act as a proxy for MPD and fully download every track before sending it to MPD.
The configuration switch that trigger this behavior is “plgproxymethod = proxy” in upmpdcli.conf and has been introduced in umpmdpcli since version 1.3.2 (2018-09-15).

From upmpdcli manual:

plgproxymethod: Decide if we proxy (copy: fetch/serve), or redirect the streaming services streams. Using redirect is much more efficient, but the proxy has a facility to retry when a stream is dropped by the service, which seems to happen esp. with Qobuz.

Unfortunately this solution does not work with Volumio because it still uses an outdated version. I tried to install a newer one using lesbonscomptes own repository but to no avail, because of further unresolved dependencies.

Further references (among many others from a simple Google search):




Hi Nessuno, sorry but I missed the replies to this topics.
Great research on your end, so many thanks!
This gave me an idea to solve this and the pause issue. Will work on it on the weekend

Nessuno, I am trying to replicate your issue, but here I can play even 15 minutes tracks without interruptions.
On which system are you on? Can you post a setting of your playback options settings?
Just to make, sure you mention upmpdcli, but are you usign it or myvolumio?

My system hardware is an RPI 3B+ and HiFiBerry DAC+ PRO. Various SD cards of different sizes (from 8 to 64 GB) with different Volumio installations, updated or freshly flashed, both beta and stable.

I use Volumio 2.834 own MyVolumio Qobuz UI and player from an internet browser (Safari on iPad and Chrome on Android phone). I experimented with various MPD buffer dimensions as I wrote in previous posts, other settings are as per default.
I mentioned upmpdcli because I found it referenced by various sources regarding this issue, so I supposed Volumio uses it internally to pass MPD the streams of the Qobuz tracks to play.
My internet connection is a Vodafone 4G (TP Link TL-MR6400 router), with good signal strength.

I’m experiencing this issue since about six months now, previously I used flawlessly Volumio/Qobuz for more than a year. My Qobuz subscription is a HiFi one but will be upgraded at same price by Qobuz themselves to Studio Premier on next renewal. I always use CD quality for playback.

The Beethoven complete Symphony by Simon Rattle and Berliners set I referenced in a previous post is particularly problematic: I never succeeded to fully listen to a single track on Volumio (but no problems with Qobuz apps on iPad played on Volumio via Airplay).