Problem with USB disc

Hi, I have a problem with Usbridge Sig, Volumio and the usb drive (2TB). He hasn’t been reading music files for several days.

I figured it out a bit with my disk and these are my observations:

  • usb connected: folders with albums are loaded up to a certain point, usually the same. For example, 26 albums are loaded.

  • drive connected to router, mounted in volumio via Sources> Network resources. The correcting disk is mounted, as in the case of a USB connection, only these 26 albums are loaded. This drive is accessed via Browse> Music Collection> NAS. So through the same path as the usb disk.

  • disk connected to the router, but without mounting the disk as above. I enter it via Browse> Media servers. And here’s a curiosity: all music folders load very quickly. Flac files are read and played without problem, unfortunately not seeing dsd.

And now: why the problem that after usb and NAS the disk is not fully read, and Media server is ok? I have the latest soft, the previous one was the same.

Could this be a problem with deeper soft? That there is an error written and the part responsible for usb and nNAS is blocked? Because Media server works.

Or maybe some device problem? That some part of it responsible for usb / us is defective? Although, for example, a usb wifi card works ok.

Power can probably be excluded, since the disk connected to the router also causes the same problem.

Strange thing.

I checked in WinScp and all files on USB disk have Chmod 0777.

Hello, it has happened to me several times that the music library loaded on my HDD (connected via USB) was only partially loaded.
Each time I found that some files had become corrupted and that this was causing the partial loading of the library.
The same thing might have happened in your case.
I found a way to detect if there are any corrupted files in the music library and I described it HERE.
Try to take a look :slight_smile:

1 Like

Thank you for your help. I had a lot of bugs, deleted those albums but it didn’t help completely.

Another thing I did was remove unnecessary files from folders: cue, pdf etc.

Later I changed the folder settings: I removed “Read only” for all folders and gave full permissions to everyone in “Security”.

There were entries of this type in the log: “Disk / $ RECYCLE.BIN / S-1-5-21-4268262462-2278025415-2522216608-1001 / $ RGZ6IKC / 07 Oboe Concerto In C - II. Allegro.flac”. The Recycle.bin folder is hidden on the disk. In the folder options I displayed it, and in the Trash options I deleted the Recycle Bin from the music disc, reducing it to 1MB.

Two folders with dsd working, as soon as I add a folder with flac files it stops working.

Ok, I created a new folder on the disk with a different name than before. I copied several albums, going from the end of the album list, plugged into the raspberry to have it loaded, and kept doing so until I uploaded all the flac albums. And it works. A strange thing. We’ll see how long.

1 Like

I’m glad you solved the problem, somehow.
Something worse happened to me today.
As I wrote before, these episodes have often happened to me.
But today, just after replying to you in this topic, a new and even more serious thing happened: I tried to upload an album via FTP as I often do (I have the PC in a room and the Raspberry with Volumio and the hdd USB in another one) but I couldn’t, as it returned an error.
Trying to browse the disc, I realized that the parent folder containing ALL my music files disappeared. Gone. 350 GB of music files. And I don’t know how it happened, since until last night I had listened to albums through Volumio.
Fortunately I had a backup on my PC and I recovered everything, but it is evident that the fragility of this system is too high.
Does anyone reading the topic have suggestions on how to avoid these problems?

I feel sorry. It’s good that you got them back. I also think that Volumio is underdeveloped and I am surprised that they charge money for it.


i have never bern charged for reading files from an USB disk - and for me it is working without any issue - no clue what is going on there

Maybe you should explain your setup more in detail