Problem with pydpiper

I’m not having trouble using the pydpiper software, in very few occasions I need to shutdown, disconnect the power cable and restart. But most of the time it works like a charm.

Hi Sayato
In the previous message I forgot to mention that I installed your plugin …
In these days I did some tests: from a clean volume I installed pydpiper from the dhrone repository and everything works well apart from the 12h time with the timezone set at Europe / Rome (I would like 24h) and the fact that, always time, it updates every 5 min (perhaps due to the fact that I activated weather underground … maybe the time takes it from there and not from the raspberry).
The problem of the double instance comes from the plugin (at least for me), I found it with 3 clean installations …
I would like to have pidpyper control from the plugin, but I can safely go on like this :slight_smile:
Thanks again for the answer

Hi Paolo,

I’m holding back the latest version of that plugin, I’m still testing it. Sometimes the connection to the screen is lost and it needs to be unlinked from power entirely (pull the plug so to say) for a few seconds.

The main reason I’m testing, is that I’m trying to avoid using the Volumio password for an edit action in the systemd unit file.

I’m however close to releasing the new version, which will have better control and updates time every 1 minute with an 24h format.


Hi Sayato
If you are interested, when the problem occurred I took off the 5v display and reconnected … pydpiper restarted and it was fine until the restart of volumio; in fact, from ssh there was only one session of docker and pidpyper …
At boot, the display started correctly and then got dirty when, after 1.5 / 2 minutes, a second session of docker and pydpiper started …
However I can not wait to fix (unfortunately I do not have the ability), manage pydpiper plugin is a great convenience.
Thank you so much for your work

(sorry for my bad english)

Hi Paolo,

No worries, your English is good enough :wink: As long as I understand it, we’re good to go.

I’ve just uploaded the new version on github, it’s ready for testing. However if you are using an I2C HD44780 display, you might want to use instead of my edited; it still has some errors. The however does not have a 24h format… working on it still :wink:


Update: also weather is not fully supported I think… I have not tested this.

Ciao Saiyato
I want to use another microsd to install volumio and your plugin …
I want to try the new version.
Since the readme in your github is missing, you can write me the exact procedure to install it … :laughing:
I do not remember how I did it :blush: … and how to update it when you change it next time …
Sorry for bothering you


Hi Paolo,

You can install it by hand, or do this:

sudo wget -O

Wait for it to download the file, you might need to enter the volumio password. And then this:

sh Saiyato volumio-pydpiper-plugin

It’s explained here

Apologies for necroposting - but I have an identical issue to Paolo. New Volumio install with Saiyato’s Pydpiper plugin - installed as per instructions.

I’m using an I2C SSD1306 128x64 OLED display.

All works fine for the first minute or two, then I get display corruption.

Initially I have just one docker when the display is OK. When the display starts corrupting there is a second docker. Restarting docker then fixes it.

I don’t know if this is being developed still - but it’s a very useful little plugin to help configure Pydpiper displays. It’s a pity that there appears to be this ‘double docker’ issue.

Hi there,

I’ve been kept quite busy lately, can you create an issue on github and provide me with some details; platform/Volumio version/plugin version?
Also can you easily reproduce? That’d help, I have several Pi’s and an SSD1306, so if you can provide me with the necessary steps, I’ll be more than happy to take a look.

Hi I have installed pydpiper on volumio 2.565 and it took a bit of fiddling to get anything to happen on a 20x4 lcd screen, i am new to all of this, however it does start and work fine for about 2 minutes and then all i get on the screen is rubbish symbols and text with an underlining bit of what should be there displayed. Is there a fix for this thanks.

Yes, it doesn’t work on RPI3 B+.

parallel connection:
i2c (pcf8574) connection:
Winstar VATN LCD 20X4.

I seems to work fine on mine except only for a few minutes then it is scrambled. If I use putty and put in ‘sudo systemctl restart docker’ it works till next reboot. If there was away to put that bit of code into pydpiper as an automatic command after say 1-2 minutes, it would work fine I suppose but no one has responded to my request on how to do that

I have 2 identical RPI3b+ with the latest version of Volumio on them, which I think is 2.599 and pydpiper 1.3.5 the only difference is one has a DAC attached and the other a Digi-amp.
Well the 20x4 LCD is working fine on one with no scrambled letters without having to use putty to restart docker etc but still scrambled on the other.
The one with the digi-amp and 19volt power supply is working fine and stable, no need to restart docker, the other with the DAC has issues still.
what do you think?

I got a pydPiper program working on volumio 2.632. It works after installing as instructed at dhrone/ pydPiper So I think that my hardware is fine and healthy. I have 16x2 hd44780 attached to I2C.
After Volumio reboot LCD showing about 11.40 am, then freeze and crash both pydPiper and Volumio.
I tried to install Saiyato pydPiper plugin, using ‘volumio plugin install’ , but it always stucks with ‘Downloading plugin’ message and nothing more. It might be a bug in 2.632 version, or my wrong operations with software.
If somebody knows, is there a good way to prevent pydPiper and/or docker from booting before Volumio webUI. I think that another boot order will give me a ability to use Volumio without a fatal crash. Also the time or the welcome words on LCD must apppear after the end of process and inform user that all is ready.
Many thanks for your possible answers.

Hard trying bring me a result. I’ve happily installed Saiyato volumio-pydpiper-plugin and it works as written. There was no need in sudo during installation process.
Now I have a common problem with two copys of docker conteiner with pydpiper. One is running from very start of Volumio and next one brings a garbage to LCD. I stopped plugin in webUI just after configuring and checking of work. The result is the only one prunning conteiner.
I also corrected ‘pydpiper.service’ file, set ‘restart=no’ instead of ‘restart=always’. I did it with all copies that I could find.
The result was the same - one conteiner started before webUI was ready and before the music roll out.
It’s not so bad, but after all Volumio freezes before music begining.
I have no any ideas what is the next step.

At last I stopped the first of two docker containers using ‘sudo docker ps’ to know the conteiner name and ‘sudo docker stop container-name’.
The second copy of pydpiper didn’t start as I disabled plugin in webUI. This two things helped Volumio to boot till the music beginning.
When I switched plugin to ‘on’ in webUI Volumio hangs down with green raspberry light continiously active.
Who can tell me about any ideas?


Do you have some more information, what exactly did you install and how? Also from what source are you playing music and what type of Pi are you using? That way I can build a lab and try to reproduce, otherwise I can only guess as to what’s happening exactly.


and thank you for quick answer.

I have Volumio 2.632 working on Raspberry Pi 3B+ with HiFiBerry Digi+ Pro. Some official plugins was installed: ‘Autostart’, ‘GPIO Buttons’, ‘Backup & Restore Data’. Also I have installed LIRC and other files to control Volumio with ir remote. The new ‘dtoverlay=gpio-ir’ is used to make this compatible with 2.632 version. More then 100000 music files stored on Synology NAS and the DAC is chinese dual ak4497. The simple hd44780 16x2 lcd attached to I2C 0x27 port. It all is working fine and correct. Only one thing is bad: it takes 12 minutes or more to boot from the ‘power on’ to the beginning of music. It’s common problem with all Volumio implementations on big music bases.
If you want music, be patient for 12 minutes or never switch off the device.

I can make a full backup of SD card with this system on my big computer and also I can restore it to previous steps.

I can install the hd44780-plugin as it discribed at help-with-volumio-plugin-install-t9987-10.html
and all works fine and correct. Many thanks to you, who wrote and made this plugin working.
But… need to do the best of the bests, always. PydPiper is the best program to show on lcd.

When I install volumio-pydpiper-plugin it works. Lcd shows all that I want, and it is great programm and very usefull plugin.
Until the reboot of Volumio.

The sequence is:
Volumio starts and after 2 minutes of booting pydPiper begin to show welcome message and then time. Then time on lcd freezes and the garbage simbols are on lcd. That is all because Volumio crashes aftee 7 or 8 minutes of booting and never get to the end. So no music, no Volumio. When it happens I see the continiously lighting green led on RPi board. Normally it blinking during operations with SD card.

I can make a SSH connection on the 3 minute of booting Volumio. There I see the one copy of working docker container with pydPiper, then there are two copies of pydPiper and then a crash interrupt SSH connection.

I did the following:
I disabled plugin in webUI whithout uninstalling.
I wrote ‘restart=no’ to ‘pydPiper.service’ file instead of ‘restart=always’. I did it in all directories where I could see thi file.
I deleted ‘pydpiper.service’ from ‘etc/systemd/system/’.

After that I saw only one docker conteiner with pydPiper, it starts from second minute, shows ‘welcome’ and time. There is now any other copies of pydPiper. From this moment I can stop it manualy with ‘docker stop conteiner-name’. Once I did it and have heard the music after twelve minute of booting. It’s not usefull because Volumio crashes shortly after enabling pydPiper. Act led lighting in green, ssh stops. Reboot with ‘power of’ produces the same situation.

If I have time I’l try to do it with clean system whithout link to Synology, with fast booting and without other plugins and LIRC files.

Thank you.

This helps like a lot, I will try to reproduce on my 3B+ instead of the 3B I use normally. That Pi is a bit different from the previous ones, so the difference might be in the Pi3B+… Will check, but it’ll take some time to investigate, don’t expect a fix this week :stuck_out_tongue: (I won’t be home a lot)

I’ve got some results with clean Volumio 2.657.
Installation consists of pydPiper plugin, ir controller plugin, gpio buttons plugin, backup& restore plugin and autostart plugin. All of them are working right after installation. I have not mount music on NAS. So all tests was done with the webradio.
After reboot I see pydPiper starting before the music begins and all is fine. Then webradio starts with music. LCD shows info about it during some seconds, and then begins to show blinking garbage. I did ‘docker ps’ and saw two containers. One running from the start and the second making garbage on display, because of two copies of pydpiper are fighting for one display.
I can stop them by ‘docker stop name’ and start again pydPiper (only one). After this it is working till next reboot.
I’ve tried to set pydPiper plugin to off in webUI. Then all is fine: plugin starts before music (why? it was set to off?) and correctly run whithout garbage on screen. ‘docker ps’ shows one running conteiner.