Problem with booting - RPI 3B+

Hi, I am using Raspberry PI 3B+. I have a problem that has been occuring for last 2 month, and right now it left me completely helpless.
My RPI 3B+ with volumio could work for days without any problems, and suddenly it stops, resets itself and everything comes back to normal. Sometimes it would lag so I had to shut it down, restart and everything was ok. Sometimes it woul not start after turning the power back on, so I had to reflash the SD card. For past couple weeks I can’t even boot the system properly. I have been trying to flash various volumio versions, sometimes the hotspot would appear in WIFI network, but after typing password it would think for a while, connect but then nothing happens. The first setup did not appear. When something like that happened before, I flashed previous version of volumio and it usuall worked fine then.
I changed computers that flashed microSD card, tried different etchers, tried different microSD cards. No effect. Right now I’m waiting for official RPIpowers supply 5,1V/2,5A to arrive. I am currently using 5V/2.3A old jbl power adapter with microUSB-USB cable. Do you think this might be the case?
Did anyone have similar problem? Does anyone have any idea how to solve it? Please help, I haven’t been streaming music for almost a month!

BAd PSU is a know source for problems, add heat to it and you horror scenario is complete. you can also check if there is a pattern in the green and red led that might give you a clue.


Hi, new PSU has arrived and the system booted without hesitation. Turns out that was the reason all the time. Thank you for you suggestion!

Thanks for your feedback!