Problem mounting Synology NAS


I can’t mount my synology folder. I tried with vers=1.0 option (and with 2.0 an 3.0) but it doesn’t work.
I can fully access to this folder with my Win 10 laptop and with my Ubuntu 20.04 laptop too.

Please help me…

Raspberry PI 4

I have done exactly like in help guide…
Only volume/music… Nfs and done
On server side : give nfs permission on music folder to volumio ip and put Mapp all user to admin…

Did you check the user and the user rights for this folder on your NAS via DSM? Does your admin user has the right to read/write the folder? Better you create an own user for your music folder on the NAS with a separate password. IMO you have to connect volumio to this folder via these credentials.
Aa a work around: Install the Logitech Media Server on the NAS, than you will get access via “Media Servers” in Volumio to this folder.

My config with synology works perfectly

Yes, rights are OK. As I said, you can fully acces to the share folder with a PC (Linux and Win 10) with the NAS user account. I use a specific user for the usic folder.

Same config here. But it doesn’t work :frowning:
I really do not understand.

It works very well that way indeed. Thank you Lintbf.

But I rally want to make it work with cifs/smb. At least, I want to understand why it does not work.

It does not work with me also with a DS 115. user and rights are set up. I get the following error message: (95) Operation not supported Refer to the mount.cifs (8) manual page (e.g. man mount.cifs)
Bildschirmfoto 2020-05-14 um 18.29.28.png

Why do not use nfs…

I am having the same problem mounting my Synology NAS after upgrading my PI. It was working fine with the old PI and I made notes of the settings and the current ones look the same. These are the results of my checks.
Using PuTTY to do a showmount request.

volumio@volumiopnb:~$ sudo showmount -e Export list for /volume1/Music

Screenshot of V’ setting page attached. Unless I am getting data blind, they look correct!

I have no record of setting a user and password but tried my admin details for the NAS but it didn’t solve the problem.


Remove the slash before volume…
No need for user and pass for nfs…

There are a number of posts on here, which seem to confuse accessing the NAS by cifs and nfs. These are two totally different protocols and have different requirements in their setup. For cifs, you need username, password and you may need to set the “vers” number. For nfs, you do not need a username or password, but you do need to set the permissions correctly on your NAS to allow the IP address of your Volumio device to access it.

I have realised why I could not mount my NAS folders, it was because my NAS had my old PI’s IP (Shared Folder>‘FolderName’>NFS Permissions) and the fresh install of V’ was getting a different one at initialisation.
I had to ignore the Sources part of setup , complete the rest, then when V’s desktop opens change the Network settings to the ‘old’ IP, then provide the Network drive folder details.
Hope this helps others in the same situation. :slight_smile: