Pop between tracks

Hi

I have recently installed Volumio on a Raspberry Pi 3 with an IQ Audio Dac + Pro. I am streaming to it over Ethernet via Airplay, from a recent model Macbook Pro.

It all works out of the box. Except that, between tracks, there is always an audible ‘pop’ as one song finishes and the next begins. It’s quite loud, and it happens on both Spotify and Tidal (I’m streaming both from my Mac to the Pi over Airplay). It always happens - ie it isn’t intermittent - and it’s driving me nuts.

I can’t see anybody else complaining about this though. Anyone got any ideas what the problem might be? When songs are actually playing it sounds fine.

Cheers

Rob

Sorry Rob, no answer really. As you say it’s not been reported on the forums here as far as I am aware. It sounds like a hardware problem to me.

Hi Rob,

Share my experience. I have DIGI+ on my Pi-3 running Volumio latest version, streaming to JOBSYS Integrated amplifier via SPDIF, which encounters exactly the same behaviour as you, got a “pop”/“click” sound between tracks playback WAV or FLAC up to 24 bit 192kHz. I think it is the JOB detects and locks down the digital signal. I do expect it happens between album of different bit depth or sampling rate, but definitely not between tracks in same album of same format. Using the same source setup, this issue has never occured on my previous DAC/Amp Hegel H80.

I changed to use the USB instead of SPDIF output of Pi-3, and it resolves the “pop”/”click” sound in between each track on playback PCM. However, I still encounter the same behaviour on DSD playback. I found an article google.com.hk/url?sa=t&rct=j … -E9H4fL1SA explains why there is “pop” for DSD playback.

The suggested solution is using some music player software like JRiver v19 which can handle the DSD output level change between track. I have tested JRiver and Foobar2000 on Windows10, both did not notice this behaviour. However, in term of sound quality, I prefer Volumio. So I think I will wait for its next release which hopefully will resolve the problem.

Though I am using Linux or Windows (sorry,… I’m Apple hater), hope my experience helps the support team to understand the problem, and improve in future release. I believe it is not hardware problem on DAC, it should be caused by the software.

Regards,
Matthew

1 Like

Did you solve this? I have the same problem with a IQaudIO Pi-AMP+, see here: pop-sound-between-tracks-with-iqaudio-amp-t7710.html

Just sharing my experience:

Pi3+IQaudIO DAC Pro

To avoid any problem, flash the version found on iqaudio download section. Is the latest volumio version already configured to work with their dac’s. Just select DAC+ from the output devices and you should good to go.

I tried many albums with linked songs ( the inability of many system to reproduce them gapless was driving me mad) and they play without any audible transition or noise.

Hope may help.

L

Thanks for sharing. It says on the IQAudio website

So I don’t think it matters that much whether or not you use their version. If you use the ‘generic’ version it’s just a matter of selecting your DAC/amp and restart the Pi, so not that much of a hassle.

Anyway, I’d love to hear other experiences with pops and sounds between tracks!

Similar issue here running volumio on Raspberry Pi 2B with Pimoroni pHAT BEAT amplified stereo DAC. Prior to this I was running a similar setup except on a Raspberry Pi Zero W (Pimoroni Pirate Radio kit). With both setups, a loud pop occurs every time I click on a track or internet radio station to manually start playback. It also occurs when resuming playback after pausing it. It does not occur between tracks when playing tracks from the queue. In fact, when playing from the queue, the automatic transition from track to track is very smooth and gap-less. However, if I click on a track in the queue to switch tracks manually (instead of letting the system move to the next track automatically at the end of the current track) I get the pop.

BTW I had the same issue while running the Pimoroni Pirate Radio script on the Pi Zero W using the pHAT BEAT. Loud pop whenever I switch internet radio station.

If you hear the pop noise whenc manually switch between songs, increasing Buffer Before Play parameter (Playback Options) to 10% or even 20 should help.

L

Hi all,

I have the same popping between tracks issue, both with playing music from NAS and Spotify.

-My setup is a RPi Zero connected to a Chordette Gen USB/BT DAC (whathifi.com/chord-electron … gem/review).
-When i connect the DAC to my laptop and play music from same sources there is no popping.
-Both RPiZ and laptop use Wifi.

-I played around with different buffer sizes and Buffer before play settings, which did not help.
-Popping both with and without softmixer volume control.

I had the same issues with a first version Pi and older versions of Volumio, the reason i try Volumio once in while to see if the problem is fixed.
It seems to mee it has something to do with the inner workings of Volumio, or stuff it uses like mpd.

Regards,
Sander

Same thing with rp2 and justboom dac. I tried also on osmc and the pop sound is there. Pop sound happen when clicking on a track to play, or pause… Very annoying, and don’t know how to get over it… Here is my original question about it:

When pressing play or pause, i have a small pop sound… Is it a known issue with the justboom dac? I would love to hear other users with this dac who have encountered this problem…

In tried changing every setting and even wifi/ether net and nothing works. Still pops between manually songs selection. Is it known bug or my dac ia faulty?

Hi all,

I think you might find this interesting.

I have a RPI zero and RPi model B which i used with Volumio and a Chordette Gem USB DAC, which i connected to an old Rotel Amplifier.

When switching tracks on NAS, Switching tracks on Spotify or switching radiostations: Pops and cracks.

A couple of days ago I bought a new streaming receiver (NAD C338) and connected the RPi / DAC combo to this new receiver.

Surprise surprise: Pops are gone!!

The difference is that the new receiver has a grounded power plug (CEE 7/4 “Schuko”) whereas the old Amp has a non grounded plug (CEE 7/16 “Europlug”). All else in the chain is the same.

(A while ago i replaced the RPI with an old laptop. This laptop also has a grounded power plug. And also: Pops where gone.)

So, i’m not an expert, but it seems that grounding issues in the whole chain might be a (or the) cause for the pops.

Cheers,
Sander

It should have been fixed in kernel 4.10. Volumio is running 4.9.
See https://patchwork.kernel.org/patch/9470981/

Between some tracks I hear a pop. Also directly at the start Play and few seconds after pause there is a pop.
I found the SPDIF light is switched off, on respectivelly. This corresponds to the pop I hear.

My devices + signal chain:
Raspberry Pi 2 Model B
Volumio 2.452 (no Plugins installed). Software mixer, no audio resampling
HiFiBerry Digi+ Standard, using S/PDIF out
Audioengine ModelD1 24-Bit DAC
Headphones

It seems the pop is generated within the external DAC/Amplifier who looks like some Kind of sensitive. I could imagine, if Volumio will ensure contious digital data stream, then my pop should be gone.

Is this definitely an issue with Volumio?

I have a customer reporting this issue with the ApplePi DAC.

I don’t know what version they are running right now.

Samething here…

Rasberry pi 3, Hifiberry DAC+ Pro XLR, Last version of Volumio and Spotify connect app… Rotel pre-amp/amp, B&W speaker…

Settings: I’ve increased to 20% playback…

Really annoying… Increasing buffer did not totally solve songs switching but do help a bit… but that have no impact on Pause/Play tic sound…

Any news about this issue … ?

I read somewhere that certain DACs are prone to this.

I was trialling Rpi with Hifiberry and into one older DAC I have (DPA enlightenment) and got pops.
Into the newer Najda DAC/DSP XO there were no pops.

Now I’m going Rpi -> Najda with I2S I get a more muffled thud rather than a pop.

In general I think I have clocking issues with I2S (poor / strange SQ), so I’m getting a Kali reclocker board to try.

Sent from my Moto G (5) using Tapatalk

Just getting this now:

Allo Boss DAC
Pi 3b+
Spotify Connect

Using Spotify and RPi/Kali all is quiet.
When playing Flacs from a NAS drive I remember getting a pop whenever the bit rate changes.

But actually…
I tried formats 24/96, 24/192 from NAS over and over last night and with Sampling rate in Volumio set to 32 / 192. I get no clicks or pops.
It was Allo who recommend 32bit… they told me 24 does not work properly with their Kali reclocker.
So that’s what I use.

Sent from my Pixel XL using Tapatalk

Hi I am not sure if you had any more luck since, but I tried a couple setups myself.
I have tried with volumio version nov 2018 till latest.
RP 2 and 3 A and B+ and Zero W
pHAT DAC - no problem at all - just use the jack output and link direct to an amp - no pop between tracks
But using speaker HAT or speaker bonnet with all type of RP versions, it generates a pop noise each time you press start and stop playback or station change on web radio. I tried with 8, 4 and 2 Ohm speaker and extreme with isolated audio transformer which reduced the signal a lot but also killed the pop sound.
I assume that the problem is related to the offset voltage of the 3W amplifier like it is not set properly, I also tried using different power supplies, but no luck either. Did anybody tried it with a HiFiBerry Pi Zero MiniAMP? I am wondering if it is worth to power the mini amp with a separate 5V power supply and see what happens.